summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-14 10:05:37 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-22 21:26:31 -0400
commiteb8dc40360f0cfef56fb6947cc817a547d6d9bc6 (patch)
treede291a73dc37168da6370e2cf16c347d1eba9df8 /meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
parent9c3cf826d853102535ead04cebc2d6023eff3032 (diff)
downloadtalos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.tar.gz
talos-openbmc-eb8dc40360f0cfef56fb6947cc817a547d6d9bc6.zip
[Subtree] Removing import-layers directory
As part of the move to subtrees, need to bring all the import layers content to the top level. Change-Id: I4a163d10898cbc6e11c27f776f60e1a470049d8f Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch104
1 files changed, 104 insertions, 0 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch b/meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
new file mode 100644
index 000000000..f4a175cdf
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/uml-utilities/uml-utilities-20040406/fix-ldflags.patch
@@ -0,0 +1,104 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- tools/mconsole/Makefile~fix-ldflags 2003-02-08 05:10:08.000000000 +0100
++++ tools/mconsole/Makefile 2004-04-01 15:37:37.000000000 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS) -lreadline -lncurses
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS) -lreadline -lncurses
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/jailtest/Makefile tools/jailtest/Makefile
+--- tools.orig/jailtest/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/jailtest/Makefile 2017-04-03 16:00:04.857449005 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/moo/Makefile tools/moo/Makefile
+--- tools.orig/moo/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/moo/Makefile 2017-04-03 15:59:56.466449432 +0200
+@@ -10,10 +10,10 @@
+ all : $(BIN)
+
+ uml_moo : $(uml_moo_OBJS)
+- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
++ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
+
+ uml_mkcow : $(uml_mkcow_OBJS)
+- $(CC) $(CFLAGS) -o $@ $($@_OBJS)
++ $(CC) $(CFLAGS) -o $@ $($@_OBJS) $(LDFLAGS)
+
+ $(uml_moo_OBJS) $(uml_mkcow_OBJS) : cow.h cow_sys.h
+
+diff -uNr tools.orig/port-helper/Makefile tools/port-helper/Makefile
+--- tools.orig/port-helper/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/port-helper/Makefile 2017-04-03 15:59:41.251450208 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/tunctl/Makefile tools/tunctl/Makefile
+--- tools.orig/tunctl/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/tunctl/Makefile 2017-04-03 16:00:01.091449197 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/uml_net/Makefile tools/uml_net/Makefile
+--- tools.orig/uml_net/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/uml_net/Makefile 2017-04-03 16:00:12.449448618 +0200
+@@ -14,7 +14,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/uml_router/Makefile tools/uml_router/Makefile
+--- tools.orig/uml_router/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/uml_router/Makefile 2017-04-03 16:00:46.796446867 +0200
+@@ -13,7 +13,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
+diff -uNr tools.orig/watchdog/Makefile tools/watchdog/Makefile
+--- tools.orig/watchdog/Makefile 2017-04-03 15:56:02.068461380 +0200
++++ tools/watchdog/Makefile 2017-04-03 15:59:45.216450006 +0200
+@@ -7,7 +7,7 @@
+ all : $(BIN)
+
+ $(BIN) : $(OBJS)
+- $(CC) $(CFLAGS) -o $(BIN) $(OBJS)
++ $(CC) $(CFLAGS) -o $(BIN) $(OBJS) $(LDFLAGS)
+
+ clean :
+ rm -f $(BIN) $(OBJS) *~
OpenPOWER on IntegriCloud