summaryrefslogtreecommitdiffstats
path: root/meta-openembedded/meta-oe/recipes-extended/sedutil
diff options
context:
space:
mode:
authorAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:03:50 -0600
committerAndrew Geissler <geissonator@yahoo.com>2019-02-22 16:05:07 -0600
commit1548c07ccf17a3a7a4fad7f31fb62d117bcb674f (patch)
treedc38b5d3eba36dab80ecd70556e05f4fae917c12 /meta-openembedded/meta-oe/recipes-extended/sedutil
parent8704effb21a9aac3e4c97d234149887b6acfa941 (diff)
downloadtalos-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.tar.gz
talos-openbmc-1548c07ccf17a3a7a4fad7f31fb62d117bcb674f.zip
meta-openembedded: refresh thud: cca27b5ea7..6ef9657068
Update meta-openembedded to thud HEAD. Alexander Kanavin (2): packagegroup-meta-oe: drop ptest packages that do not exist packagegroup-meta-oe: rename the group that contains ptest packages Andrea Adami (4): klibc: fix build for mipsel and mips64el with security flags enabled waf-cross-answers: Add cross-answers-mips64el.txt kexec-tools-klibc: fix build for mipsel and mips64el samba: fix build on qemumips64 with musl Andreas Müller (1): libgit2: Fix install for multilib Armin Kuster (1): wireshark: update to 2.6.6 Craig McQueen (1): python3-multidict: Workaround for broken make clean Eduardas Meile (1): toybox: fix to use "usrmerge" distro feature properly Haiqing Bai (1): ptpd: fixed the issue of ptpd2 daemon takes 100% CPU Hong Liu (1): wireshark: upgrade to 2.6.5 Hongxu Jia (1): python-pyparted/python3-pyparted: drop incorrect and redundant PV Kai Kang (1): net-snmp: inherit ptest Khem Raj (16): xscreensaver: Define consistent app-defaults dir a2jmidid: Define own do_configure bpftool: don't build under musl packagegroup-meta-oe: Remove arch specific packages as needed packagegroup-meta-oe: Remove packages which don't build for musl modemmanager: Fix build with clang klibc: Fix build with clang srecord: GPL-3.0 and LGPL-3.0 is correct license packagegroup-meta-oe: Exclude unbuildable packages on mips64 packagegroup-meta-oe: Exclude android-tools breakpad on ppc packagegroup-meta-oe: Remove unbuildable packages on risc-v from rdep mpv: Disable lua on mips/aarch64 luajit: Disable for mips n64/n32 hosts licenses: Add Arphic-Public-License text nmap: Fix build with clang8/musl/libc++ mozjs: Fix symbol visibility with clang/libc++ Marc Ferland (1): networkmanager: fix QA issue when using modemmanager and ppp in PACKAGECONFIG Martin Jansa (1): open-vm-tools: fix indentation and drop FILES_${PN}-dbg Mingli Yu (1): vim: improve reproducibility Niko Mauno (7): python-pygobject: Fix invalid install path python-pygobject: Drop redundant PYTHON* refs python-pygobject: Drop redundant dependencies python-pygobject: Only check for even upstream versions python-pygobject: Remove duplication in inherit python-pygobject: Fix style issue python-pygobject: Tune remove operation Otavio Salvador (2): mozjs: Avoid use of X11 from host when X11 is disabled postgresql: Allow successful run of postgresql-setup Primoz Fiser (1): sedutil: fix compile errors on big endian architectures Scott Ellis (2): nmap: Fix typo in pcre PACKAGECONFIG nmap: Include additional FILES path for certs leimaohui (2): mraa: To file do_package error in multilib. makedumpfile: Add aarch64 into COMPATIBLE_HOST. thc (1): fix networkmanager apppend Change-Id: I979f5ccefeec364f27df10888ae6258923a30659 Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-openembedded/meta-oe/recipes-extended/sedutil')
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-Fix-build-on-big-endian-architectures.patch41
-rw-r--r--meta-openembedded/meta-oe/recipes-extended/sedutil/sedutil_git.bb4
2 files changed, 44 insertions, 1 deletions
diff --git a/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-Fix-build-on-big-endian-architectures.patch b/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-Fix-build-on-big-endian-architectures.patch
new file mode 100644
index 000000000..7351197e4
--- /dev/null
+++ b/meta-openembedded/meta-oe/recipes-extended/sedutil/files/0001-Fix-build-on-big-endian-architectures.patch
@@ -0,0 +1,41 @@
+From ff98a326d5faa585f0e15e51a558cc2c49aa8099 Mon Sep 17 00:00:00 2001
+From: Primoz Fiser <primoz.fiser@norik.com>
+Date: Fri, 23 Nov 2018 08:31:29 +0100
+Subject: [PATCH] Fix build on big endian architectures
+
+Signed-off-by: Primoz Fiser <primoz.fiser@norik.com>
+---
+ Common/DtaEndianFixup.h | 13 +++++++------
+ 1 file changed, 7 insertions(+), 6 deletions(-)
+
+diff --git a/Common/DtaEndianFixup.h b/Common/DtaEndianFixup.h
+index 58eb3ff..184fce0 100644
+--- a/Common/DtaEndianFixup.h
++++ b/Common/DtaEndianFixup.h
+@@ -31,12 +31,11 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
+ //TODO: add a test on the endianess of the system and define
+ // empty macros if the system is big endian
+ #pragma once
+-#ifdef __gnu_linux__
+-#include <endian.h>
+-#if __BYTE_ORDER != __LITTLE_ENDIAN
+-#error This code does not support big endian architectures
+-#endif
+-#endif
++#if defined(__BYTE_ORDER__)&&(__BYTE_ORDER__ == __ORDER_BIG_ENDIAN__)
++#define SWAP16(x) x
++#define SWAP32(x) x
++#define SWAP64(x) x
++#else
+ /** change the "endianess" of a 16bit field */
+ #define SWAP16(x) ((uint16_t) ((x & 0x00ff) << 8) | ((x & 0xff00) >> 8))
+ /** change the "endianess" of a 32bit field */
+@@ -47,3 +46,5 @@ along with sedutil. If not, see <http://www.gnu.org/licenses/>.
+ ((uint64_t) (SWAP32((x & 0x00000000ffffffff)) << 32) | \
+ ((uint64_t) (SWAP32((x >> 32))) ) \
+ )
++
++#endif
+--
+2.7.4
+
diff --git a/meta-openembedded/meta-oe/recipes-extended/sedutil/sedutil_git.bb b/meta-openembedded/meta-oe/recipes-extended/sedutil/sedutil_git.bb
index cec569f62..765618433 100644
--- a/meta-openembedded/meta-oe/recipes-extended/sedutil/sedutil_git.bb
+++ b/meta-openembedded/meta-oe/recipes-extended/sedutil/sedutil_git.bb
@@ -10,7 +10,9 @@ LIC_FILES_CHKSUM = "file://Common/LICENSE.txt;md5=d32239bcb673463ab874e80d47fae5
BASEPV = "1.15.1"
PV = "${BASEPV}+git${SRCPV}"
SRCREV = "358cc758948be788284d5faba46ccf4cc1813796"
-SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git"
+SRC_URI = "git://github.com/Drive-Trust-Alliance/sedutil.git \
+ file://0001-Fix-build-on-big-endian-architectures.patch \
+"
S = "${WORKDIR}/git"
OpenPOWER on IntegriCloud