summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 11:53:03 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-02 13:43:07 +0000
commit3acb95c97521320122bdd1c735226a597c1b4363 (patch)
tree38cbbeb8183695a6e3b8ef269785d81576ab4258 /meta-openbmc-machines
parent961df760805a18770a897998a2617f24766d0a47 (diff)
downloadtalos-openbmc-3acb95c97521320122bdd1c735226a597c1b4363.tar.gz
talos-openbmc-3acb95c97521320122bdd1c735226a597c1b4363.zip
ipmi: Add virtual/phosphor-ipmi-fru-hostfw-config
This virtual provides a configuration file that describes host firmware implementation details to ipmi-fru-parser. Add a recipe that provides the sample that comes with ipmi-fru-parser. Add a recipe for Hostboot on OpenPower systems. Set the default provider to the example. Set the default on OpenPOWER systems to the hostboot recipe. Change-Id: Iff56c5c0c2ea8aec7ecaa5a5d981da6f88a894f2 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb19
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml83
-rw-r--r--meta-openbmc-machines/meta-openpower/conf/machine/include/openpower.inc1
3 files changed, 103 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
new file mode 100644
index 000000000..31aee2d7c
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Hostboot hostfw inventory map for phosphor-ipmi-fru"
+PR = "r1"
+
+inherit native
+inherit phosphor-ipmi-fru
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-hostfw-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${hostfw_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml
new file mode 100644
index 000000000..ff7eec422
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/ipmi/hostboot-inventory-config/config.yaml
@@ -0,0 +1,83 @@
+PROC:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Product Name"
+
+SYS:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Product Name"
+ xyz.openbmc_project.Inventory.Revision:
+ Version:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Version"
+
+DIMM:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Product Name"
+ xyz.openbmc_project.Inventory.Revision:
+ Version:
+ IPMIFruSection: Product
+ IPMIFruProperty: "Version"
+
+MEMBUFF:
+ xyz.openbmc_project.Inventory.Decorator.Asset:
+ BuildDate:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Mfg Date"
+ Manufacturer:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Manufacturer"
+ PartNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Part Number"
+ SerialNumber:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Serial Number"
+ xyz.openbmc_project.Inventory.Item:
+ PrettyName:
+ IPMIFruSection: Board
+ IPMIFruProperty: "Product Name"
diff --git a/meta-openbmc-machines/meta-openpower/conf/machine/include/openpower.inc b/meta-openbmc-machines/meta-openpower/conf/machine/include/openpower.inc
index d6efd6c37..dd90dcc91 100644
--- a/meta-openbmc-machines/meta-openpower/conf/machine/include/openpower.inc
+++ b/meta-openbmc-machines/meta-openpower/conf/machine/include/openpower.inc
@@ -21,3 +21,4 @@ PREFERRED_PROVIDER_virtual/obmc-sensor-mgmt = "packagegroup-op-apps"
PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-op-apps"
PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-hostfw-config ?= "hostboot-inventory-config-native"
OpenPOWER on IntegriCloud