summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2018-08-13 12:29:45 +0930
committerAndrew Geissler <geissonator@yahoo.com>2018-08-16 15:34:35 +0000
commit347ca073b24d41c37644d626bc045b305eebfaed (patch)
tree85b74e79c3b83f365f2f8dd2c1eaf8eb4b7a8de1 /meta-openbmc-machines
parent9af50e2fc71de34a005461a3b0e67803034f36e5 (diff)
downloadtalos-openbmc-347ca073b24d41c37644d626bc045b305eebfaed.tar.gz
talos-openbmc-347ca073b24d41c37644d626bc045b305eebfaed.zip
openpower: Add ASPEED LPC Control tool
This includes the 'pnorboot' tool for configuring the LPC firmware mapping. This is used by Palmetto instead of mboxd, as Palmetto only requires the LPC mapping component. The mbox component causes interrupts to be continually triggered on the host, causing unnecessary CPU load. As Palmetto is the only in-tree user of this tool, the service file hard codes the PNOR size. If we merge machines in the future this should be configured by the machine layer. Resolves: openbmc/openbmc#3357 Tested: Booted host on Palmetto, checked interrupt count Change-Id: I87daafa5008e978afd3a5fc386b347b014624911 Signed-off-by: Joel Stanley <joel@jms.id.au>
Diffstat (limited to 'meta-openbmc-machines')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb15
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl/pnorboot.service9
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/images/obmc-phosphor-image.bbappend2
3 files changed, 25 insertions, 1 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb
new file mode 100644
index 000000000..f37f2bec6
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl.bb
@@ -0,0 +1,15 @@
+SUMMARY = "ASPEED LPC Host Interface Control tool"
+DESCRIPTION = "Configures the BMC to expose memory regions to the host"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit obmc-phosphor-systemd
+
+inherit autotools
+
+S = "${WORKDIR}/git"
+
+SYSTEMD_SERVICE_${PN} += "pnorboot.service"
+
+SRC_URI += "git://github.com/shenki/aspeed-lpc-control"
+SRCREV = "ab2012e749daf567049bf157c3bf037adc62c0e8"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl/pnorboot.service b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl/pnorboot.service
new file mode 100644
index 000000000..fffe13c48
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-phosphor/host/aspeed-lpc-ctrl/pnorboot.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=ASPEED LPC boot from PNOR
+
+[Service]
+Type=oneshot
+ExecStart=/usr/sbin/pnorboot --size 32
+
+[Install]
+WantedBy=obmc-standby.target
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/images/obmc-phosphor-image.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/images/obmc-phosphor-image.bbappend
index aa57bbfe6..a25b65a0e 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/images/obmc-phosphor-image.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-palmetto/recipes-phosphor/images/obmc-phosphor-image.bbappend
@@ -1 +1 @@
-OBMC_IMAGE_EXTRA_INSTALL_append = " mboxd"
+OBMC_IMAGE_EXTRA_INSTALL_append = " aspeed-lpc-ctrl"
OpenPOWER on IntegriCloud