summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-x86/meta-intel
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-22 21:40:54 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 12:39:42 -0400
commit194ff4f1f5d44b12e9cb06ddafa6adb20174a13c (patch)
tree823835cd29daf8901a31ac14c7e6534abf199be3 /meta-openbmc-machines/meta-x86/meta-intel
parent4feb727cd6b77a68bdaca63e121b378d814f5eaf (diff)
downloadtalos-openbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.tar.gz
talos-openbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.zip
[Subtree] Bring openbmc machines to top level
The new subtree model brings the subtrees up from the openbmc-machines layer. Change-Id: I58a03ae1be374bc79ae1438e65e888375d12d0c0 Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-x86/meta-intel')
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/conf/layer.conf10
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/conf/machine/include/intel.inc21
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/boost-dbus/boost-dbus.bb15
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend3
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb51
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend4
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/bblayers.conf.sample21
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/conf-notes.txt4
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/layer.conf10
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/local.conf.sample241
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/machine/s2600wf.conf12
-rw-r--r--meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config.bb5
12 files changed, 0 insertions, 397 deletions
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/conf/layer.conf b/meta-openbmc-machines/meta-x86/meta-intel/conf/layer.conf
deleted file mode 100644
index b19eca204..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/meta-common/recipes-*/*/*.bb \
- ${LAYERDIR}/meta-common/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "intel"
-BBFILE_PATTERN_intel = ""
-LAYERVERSION_intel = "1"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/conf/machine/include/intel.inc b/meta-openbmc-machines/meta-x86/meta-intel/conf/machine/include/intel.inc
deleted file mode 100644
index 088429419..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/conf/machine/include/intel.inc
+++ /dev/null
@@ -1,21 +0,0 @@
-OBMC_MACHINE_FEATURES += "\
- obmc-phosphor-fan-mgmt \
- obmc-phosphor-chassis-mgmt \
- obmc-phosphor-flash-mgmt \
- obmc-host-ipmi \
- obmc-host-ctl \
- obmc-host-state-mgmt \
- obmc-chassis-state-mgmt \
- obmc-bmc-state-mgmt \
- "
-
-VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
-
-PREFERRED_PROVIDER_virtual/obmc-chassis-mgmt = "packagegroup-intel-apps"
-PREFERRED_PROVIDER_virtual/obmc-fan-mgmt = "packagegroup-intel-apps"
-PREFERRED_PROVIDER_virtual/obmc-flash-mgmt = "packagegroup-intel-apps"
-PREFERRED_PROVIDER_virtual/obmc-system-mgmt = "packagegroup-intel-apps"
-PREFERRED_PROVIDER_virtual/obmc-host-ctl ?= "obmc-op-control-host"
-PREFERRED_PROVIDER_virtual/obmc-inventory-data ?= "${VIRTUAL-RUNTIME_skeleton_workbook}"
-PREFERRED_PROVIDER_virtual/obmc-host-ipmi-hw = ""
-#PREFERRED_PROVIDER_virtual/obmc-gpio-monitor ?= "phosphor-gpio-monitor"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/boost-dbus/boost-dbus.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/boost-dbus/boost-dbus.bb
deleted file mode 100644
index 579579b74..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/boost-dbus/boost-dbus.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-LICENSE = "BSL-1.0"
-LIC_FILES_CHKSUM = "file://LICENSE_1_0.txt;md5=e4224ccaecb14d942c71d31bef20d78c"
-
-SRC_URI = "gitsm://github.com/openbmc/boost-dbus.git"
-
-PV = "1.0+git${SRCPV}"
-SRCREV = "2ec80375259500c43f5a7c620cb34cd894f7836c"
-
-S = "${WORKDIR}/git"
-
-DEPENDS = "dbus boost gtest "
-
-inherit cmake
-
-FILES_${PN}-dev += "${libdir}/cmake/boost-dbus/*"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend
deleted file mode 100644
index 60cfe5e9d..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/libtinyxml2/libtinyxml2_%.bbappend
+++ /dev/null
@@ -1,3 +0,0 @@
-# update libtinyxml2 to version 6.0.0
-SRCREV = "8c8293ba8969a46947606a93ff0cb5a083aab47a"
-FILES_${PN}-dev += "${libdir}/cmake/tinyxml2/*"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
deleted file mode 100644
index 507f14969..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-intel-apps.bb
+++ /dev/null
@@ -1,51 +0,0 @@
-SUMMARY = "OpenBMC for Intel - Applications"
-PR = "r1"
-
-inherit packagegroup
-inherit obmc-phosphor-license
-
-PROVIDES = "${PACKAGES}"
-PACKAGES = " \
- ${PN}-chassis \
- ${PN}-fans \
- ${PN}-flash \
- ${PN}-system \
- "
-
-PROVIDES += "virtual/obmc-chassis-mgmt"
-PROVIDES += "virtual/obmc-fan-mgmt"
-PROVIDES += "virtual/obmc-flash-mgmt"
-PROVIDES += "virtual/obmc-system-mgmt"
-
-RPROVIDES_${PN}-chassis += "virtual-obmc-chassis-mgmt"
-RPROVIDES_${PN}-fans += "virtual-obmc-fan-mgmt"
-RPROVIDES_${PN}-flash += "virtual-obmc-flash-mgmt"
-RPROVIDES_${PN}-system += "virtual-obmc-system-mgmt"
-
-SUMMARY_${PN}-chassis = "Intel Chassis"
-RDEPENDS_${PN}-chassis = " \
- obmc-button-power \
- obmc-button-reset \
- obmc-control-chassis \
- obmc-op-control-power \
- obmc-host-failure-reboots \
- "
-
-SUMMARY_${PN}-fans = "Intel Fans"
-RDEPENDS_${PN}-fans = " \
- obmc-control-fan \
- "
-
-SUMMARY_${PN}-flash = "Intel Flash"
-RDEPENDS_${PN}-flash = " \
- obmc-flash-bmc \
- obmc-mgr-download \
- obmc-control-bmc \
- "
-
-SUMMARY_${PN}-system = "Intel System"
-RDEPENDS_${PN}-system = " \
- obmc-mgr-system \
- bmcweb \
- phosphor-webui \
- "
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend b/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend
deleted file mode 100644
index 54dc73d75..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-common/recipes-intel/packagegroups/packagegroup-obmc-apps.bbappend
+++ /dev/null
@@ -1,4 +0,0 @@
-RDEPENDS_${PN}-extras_remove = " \
- phosphor-rest \
- phosphor-gevent \
- "
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/bblayers.conf.sample b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/bblayers.conf.sample
deleted file mode 100644
index 5f4301b0b..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/bblayers.conf.sample
+++ /dev/null
@@ -1,21 +0,0 @@
-# LAYER_CONF_VERSION is increased each time build/conf/bblayers.conf
-# changes incompatibly
-LCONF_VERSION = "7"
-
-BBPATH = "${TOPDIR}"
-BBFILES ?= ""
-
-BBLAYERS ?= " \
- ##OEROOT##/meta \
- ##OEROOT##/meta-poky \
- ##OEROOT##/meta-openembedded/meta-oe \
- ##OEROOT##/meta-openembedded/meta-networking \
- ##OEROOT##/meta-openembedded/meta-perl \
- ##OEROOT##/meta-openembedded/meta-python \
- ##OEROOT##/meta-openembedded/meta-webserver \
- ##OEROOT##/meta-phosphor \
- ##OEROOT##/meta-aspeed \
- ##OEROOT##/meta-openbmc-machines/meta-x86 \
- ##OEROOT##/meta-openbmc-machines/meta-x86/meta-intel \
- ##OEROOT##/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf \
-"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/conf-notes.txt b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/conf-notes.txt
deleted file mode 100644
index 5314bf4e6..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/conf-notes.txt
+++ /dev/null
@@ -1,4 +0,0 @@
-Common targets are:
- obmc-phosphor-image
- virtual/kernel
- phosphor-ipmi-host
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/layer.conf b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/layer.conf
deleted file mode 100644
index 75954f623..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/layer.conf
+++ /dev/null
@@ -1,10 +0,0 @@
-# We have a conf and classes directory, add to BBPATH
-BBPATH .= ":${LAYERDIR}"
-
-# We have recipes-* directories, add to BBFILES
-BBFILES += "${LAYERDIR}/recipes-*/*/*.bb \
- ${LAYERDIR}/recipes-*/*/*.bbappend"
-
-BBFILE_COLLECTIONS += "s2600wf"
-BBFILE_PATTERN_s2600wf = ""
-BBFILE_PRIORITY_s2600wf = "5"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/local.conf.sample b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/local.conf.sample
deleted file mode 100644
index 6c0c97773..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/local.conf.sample
+++ /dev/null
@@ -1,241 +0,0 @@
-#
-# This file is your local configuration file and is where all local user settings
-# are placed. The comments in this file give some guide to the options a new user
-# to the system might want to change but pretty much any configuration option can
-# be set in this file. More adventurous users can look at local.conf.extended
-# which contains other examples of configuration which can be placed in this file
-# but new users likely won't need any of them initially.
-#
-# Lines starting with the '#' character are commented out and in some cases the
-# default values are provided as comments to show people example syntax. Enabling
-# the option is a question of removing the # character and making any change to the
-# variable as required.
-
-#
-# Machine Selection
-#
-# You need to select a specific machine to target the build with. There are a selection
-# of emulated machines available which can boot and run in the QEMU emulator:
-#
-#MACHINE ?= "qemuarm"
-#MACHINE ?= "qemuarm64"
-#MACHINE ?= "qemumips"
-#MACHINE ?= "qemuppc"
-#MACHINE ?= "qemux86"
-#MACHINE ?= "qemux86-64"
-#
-# There are also the following hardware board target machines included for
-# demonstration purposes:
-#
-#MACHINE ?= "beaglebone"
-#MACHINE ?= "genericx86"
-#MACHINE ?= "genericx86-64"
-#MACHINE ?= "mpc8315e-rdb"
-#MACHINE ?= "edgerouter"
-#
-# This sets the default machine to be qemux86 if no other machine is selected:
-
-MACHINE ?= "s2600wf"
-
-#
-# Where to place downloads
-#
-# During a first build the system will download many different source code tarballs
-# from various upstream projects. This can take a while, particularly if your network
-# connection is slow. These are all stored in DL_DIR. When wiping and rebuilding you
-# can preserve this directory to speed up this part of subsequent builds. This directory
-# is safe to share between multiple builds on the same machine too.
-#
-# The default is a downloads directory under TOPDIR which is the build directory.
-#
-#DL_DIR ?= "${TOPDIR}/downloads"
-#
-# Where to place shared-state files
-#
-# BitBake has the capability to accelerate builds based on previously built output.
-# This is done using "shared state" files which can be thought of as cache objects
-# and this option determines where those files are placed.
-#
-# You can wipe out TMPDIR leaving this directory intact and the build would regenerate
-# from these files if no changes were made to the configuration. If changes were made
-# to the configuration, only shared state files where the state was still valid would
-# be used (done using checksums).
-#
-# The default is a sstate-cache directory under TOPDIR.
-#
-#SSTATE_DIR ?= "${TOPDIR}/sstate-cache"
-
-#
-# Where to place the build output
-#
-# This option specifies where the bulk of the building work should be done and
-# where BitBake should place its temporary files and output. Keep in mind that
-# this includes the extraction and compilation of many applications and the toolchain
-# which can use Gigabytes of hard disk space.
-#
-# The default is a tmp directory under TOPDIR.
-#
-#TMPDIR = "${TOPDIR}/tmp"
-
-#
-# Default policy config
-#
-# The distribution setting controls which policy settings are used as defaults.
-# The default value is fine for general Yocto project use, at least initially.
-# Ultimately when creating custom policy, people will likely end up subclassing
-# these defaults.
-#
-DISTRO ?= "openbmc-phosphor"
-# As an example of a subclass there is a "bleeding" edge policy configuration
-# where many versions are set to the absolute latest code from the upstream
-# source control systems. This is just mentioned here as an example, its not
-# useful to most new users.
-# DISTRO ?= "poky-bleeding"
-
-#
-# Package Management configuration
-#
-# This variable lists which packaging formats to enable. Multiple package backends
-# can be enabled at once and the first item listed in the variable will be used
-# to generate the root filesystems.
-# Options are:
-# - 'package_deb' for debian style deb files
-# - 'package_ipk' for ipk files are used by opkg (a debian style embedded package manager)
-# - 'package_rpm' for rpm style packages
-# E.g.: PACKAGE_CLASSES ?= "package_rpm package_deb package_ipk"
-# We default to rpm:
-PACKAGE_CLASSES ?= "package_rpm"
-
-#
-# SDK/ADT target architecture
-#
-# This variable specifies the architecture to build SDK/ADT items for and means
-# you can build the SDK packages for architectures other than the machine you are
-# running the build on (i.e. building i686 packages on an x86_64 host).
-# Supported values are i686 and x86_64
-#SDKMACHINE ?= "i686"
-SANITY_TESTED_DISTROS_append ?= " RedHatEnterpriseWorkstation-6.*"
-
-#
-# Extra image configuration defaults
-#
-# The EXTRA_IMAGE_FEATURES variable allows extra packages to be added to the generated
-# images. Some of these options are added to certain image types automatically. The
-# variable can contain the following options:
-# "dbg-pkgs" - add -dbg packages for all installed packages
-# (adds symbol information for debugging/profiling)
-# "dev-pkgs" - add -dev packages for all installed packages
-# (useful if you want to develop against libs in the image)
-# "ptest-pkgs" - add -ptest packages for all ptest-enabled packages
-# (useful if you want to run the package test suites)
-# "tools-sdk" - add development tools (gcc, make, pkgconfig etc.)
-# "tools-debug" - add debugging tools (gdb, strace)
-# "eclipse-debug" - add Eclipse remote debugging support
-# "tools-profile" - add profiling tools (oprofile, exmap, lttng, valgrind)
-# "tools-testapps" - add useful testing tools (ts_print, aplay, arecord etc.)
-# "debug-tweaks" - make an image suitable for development
-# e.g. ssh root access has a blank password
-# There are other application targets that can be used here too, see
-# meta/classes/image.bbclass and meta/classes/core-image.bbclass for more details.
-# We default to enabling the debugging tweaks.
-EXTRA_IMAGE_FEATURES = "debug-tweaks"
-
-#
-# Additional image features
-#
-# The following is a list of additional classes to use when building images which
-# enable extra features. Some available options which can be included in this variable
-# are:
-# - 'buildstats' collect build statistics
-# - 'image-mklibs' to reduce shared library files size for an image
-# - 'image-prelink' in order to prelink the filesystem image
-# - 'image-swab' to perform host system intrusion detection
-# NOTE: if listing mklibs & prelink both, then make sure mklibs is before prelink
-# NOTE: mklibs also needs to be explicitly enabled for a given image, see local.conf.extended
-USER_CLASSES ?= "buildstats image-mklibs image-prelink"
-
-#
-# Runtime testing of images
-#
-# The build system can test booting virtual machine images under qemu (an emulator)
-# after any root filesystems are created and run tests against those images. To
-# enable this uncomment this line. See classes/testimage(-auto).bbclass for
-# further details.
-#TEST_IMAGE = "1"
-#
-# Interactive shell configuration
-#
-# Under certain circumstances the system may need input from you and to do this it
-# can launch an interactive shell. It needs to do this since the build is
-# multithreaded and needs to be able to handle the case where more than one parallel
-# process may require the user's attention. The default is iterate over the available
-# terminal types to find one that works.
-#
-# Examples of the occasions this may happen are when resolving patches which cannot
-# be applied, to use the devshell or the kernel menuconfig
-#
-# Supported values are auto, gnome, xfce, rxvt, screen, konsole (KDE 3.x only), none
-# Note: currently, Konsole support only works for KDE 3.x due to the way
-# newer Konsole versions behave
-#OE_TERMINAL = "auto"
-# By default disable interactive patch resolution (tasks will just fail instead):
-PATCHRESOLVE = "noop"
-
-#
-# Disk Space Monitoring during the build
-#
-# Monitor the disk space during the build. If there is less that 1GB of space or less
-# than 100K inodes in any key build location (TMPDIR, DL_DIR, SSTATE_DIR), gracefully
-# shutdown the build. If there is less that 100MB or 1K inodes, perform a hard abort
-# of the build. The reason for this is that running completely out of space can corrupt
-# files and damages the build in ways which may not be easily recoverable.
-# It's necessary to monitor /tmp, if there is no space left the build will fail
-# with very exotic errors.
-BB_DISKMON_DIRS = "\
- STOPTASKS,${TMPDIR},1G,100K \
- STOPTASKS,${DL_DIR},1G,100K \
- STOPTASKS,${SSTATE_DIR},1G,100K \
- STOPTASKS,/tmp,100M,100K \
- ABORT,${TMPDIR},100M,1K \
- ABORT,${DL_DIR},100M,1K \
- ABORT,${SSTATE_DIR},100M,1K \
- ABORT,/tmp,10M,1K"
-
-#
-# Shared-state files from other locations
-#
-# As mentioned above, shared state files are prebuilt cache data objects which can
-# used to accelerate build time. This variable can be used to configure the system
-# to search other mirror locations for these objects before it builds the data itself.
-#
-# This can be a filesystem directory, or a remote url such as http or ftp. These
-# would contain the sstate-cache results from previous builds (possibly from other
-# machines). This variable works like fetcher MIRRORS/PREMIRRORS and points to the
-# cache locations to check for the shared objects.
-# NOTE: if the mirror uses the same structure as SSTATE_DIR, you need to add PATH
-# at the end as shown in the examples below. This will be substituted with the
-# correct path within the directory structure.
-#SSTATE_MIRRORS ?= "\
-#file://.* http://someserver.tld/share/sstate/PATH;downloadfilename=PATH \n \
-#file://.* file:///some/local/dir/sstate/PATH"
-
-#
-# Qemu configuration
-#
-# By default qemu will build with a builtin VNC server where graphical output can be
-# seen. The two lines below enable the SDL backend too. This assumes there is a
-# libsdl library available on your build system.
-PACKAGECONFIG_append_pn-qemu-native = " sdl"
-PACKAGECONFIG_append_pn-nativesdk-qemu = " sdl"
-#ASSUME_PROVIDED += "libsdl-native"
-
-# CONF_VERSION is increased each time build/conf/ changes incompatibly and is used to
-# track the version of this file when it was generated. This can safely be ignored if
-# this doesn't mean anything to you.
-CONF_VERSION = "1"
-
-# Set the root password to '0penBmc'
-INHERIT += "extrausers"
-EXTRA_USERS_PARAMS = " \
- usermod -p '\$1\$UGMqyqdG\$FZiylVFmRRfl9Z0Ue8G7e/' root; \
- "
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/machine/s2600wf.conf b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/machine/s2600wf.conf
deleted file mode 100644
index d0ca8a3c3..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/conf/machine/s2600wf.conf
+++ /dev/null
@@ -1,12 +0,0 @@
-KMACHINE = "aspeed"
-KERNEL_DEVICETREE = "${KMACHINE}-bmc-intel-s2600wf.dtb"
-
-require conf/machine/include/ast2500.inc
-require conf/machine/include/obmc-bsp-common.inc
-require conf/machine/include/intel.inc
-
-UBOOT_MACHINE = "ast_g5_phy_config"
-
-FLASH_SIZE = "32768"
-
-VIRTUAL-RUNTIME_skeleton_workbook = "${MACHINE}-config"
diff --git a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config.bb b/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config.bb
deleted file mode 100644
index 3a92f9dd5..000000000
--- a/meta-openbmc-machines/meta-x86/meta-intel/meta-s2600wf/recipes-phosphor/workbook/s2600wf-config.bb
+++ /dev/null
@@ -1,5 +0,0 @@
-SUMMARY = "s2600wf board wiring"
-DESCRIPTION = "Board wiring information for the s2600wf system."
-PR = "r1"
-
-inherit config-in-skeleton
OpenPOWER on IntegriCloud