summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-17 12:26:30 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-01-25 04:08:20 +0000
commitb3ff4009f8863478cd2a5f38501180b175e99356 (patch)
tree3e9d49fe9965ffd903999c6fdb06686270eae563 /meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius
parente425d2ea5be21e11861f2963c9b7ca296df38a9b (diff)
downloadtalos-openbmc-b3ff4009f8863478cd2a5f38501180b175e99356.tar.gz
talos-openbmc-b3ff4009f8863478cd2a5f38501180b175e99356.zip
Phosphor IPMI FRU config stubs for Zaius
Add native recipe stub that (will) provide the the IPMI -> DBus inventory mapping for the Phosphor IPMI FRU provider on the Zaius system. Change-Id: Ibaad66d44f3421689608f852e4c565cd493126ec Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/conf/machine/zaius.conf1
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map.bb19
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map/config.yaml1
3 files changed, 21 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/conf/machine/zaius.conf b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/conf/machine/zaius.conf
index 38713cdf8..b0816cc0c 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/conf/machine/zaius.conf
+++ b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/conf/machine/zaius.conf
@@ -6,6 +6,7 @@ UBOOT_MACHINE = "ast_g5_ncsi_config"
FLASH_SIZE = "65536"
PREFERRED_PROVIDER_virtual/p9-vcs-workaround = 'vcs-control'
+PREFERRED_PROVIDER_virtual/phosphor-ipmi-fru-config = "zaius-ipmi-inventory-map"
require conf/machine/include/ast2500.inc
require conf/machine/include/obmc-bsp-common.inc
diff --git a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map.bb b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map.bb
new file mode 100644
index 000000000..21985ac39
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Zaius IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-config"
+
+S = "${WORKDIR}"
+
+do_install() {
+ DEST=${D}${datadir}/phosphor-ipmi-fru
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
+
diff --git a/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map/config.yaml b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map/config.yaml
new file mode 100644
index 000000000..b3459a9eb
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ingrasys/meta-zaius/recipes-phosphor/ipmi/zaius-ipmi-inventory-map/config.yaml
@@ -0,0 +1 @@
+# This file is a stub.
OpenPOWER on IntegriCloud