summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/meta-ibm
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2016-10-12 08:56:48 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-11-08 00:53:49 +0000
commitdadd4763e0f9b79a56a5afd975d76a0c0da90932 (patch)
tree00d35b5e63eca4f0ee9789f65f87f3c51abb8251 /meta-openbmc-machines/meta-openpower/meta-ibm
parent799758d2196507fa53cdeb745be24e1f95635dbc (diff)
downloadtalos-openbmc-dadd4763e0f9b79a56a5afd975d76a0c0da90932.tar.gz
talos-openbmc-dadd4763e0f9b79a56a5afd975d76a0c0da90932.zip
Add recipe to install device tree config YAML.
New recipe copies the devtree-config.yaml to a place the device tree generator can find it. Change-Id: I3ac107986de469ce47a4cd76cb790a8ab60988bc Signed-off-by: Matt Spinler <spinler@us.ibm.com>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb17
1 files changed, 17 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb
new file mode 100644
index 000000000..9a16dd6b3
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/workbook/devtree-config-native.bb
@@ -0,0 +1,17 @@
+SUMMARY = "Witherspoon Device Tree Configuration"
+DESCRIPTION = "Provides the device tree configuration file for Witherspoon"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit native
+
+SRC_URI += "file://config.yaml"
+
+FILES_${PN} += "${datadir}/devtree"
+
+do_install() {
+ install -d ${D}${datadir}/devtree
+ install -m 0644 config.yaml ${D}${datadir}/devtree/
+}
+
+S = "${WORKDIR}"
OpenPOWER on IntegriCloud