summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi
diff options
context:
space:
mode:
authorAndrew Jeffery <andrew@aj.id.au>2018-04-06 14:13:14 +0930
committerAndrew Jeffery <andrew@aj.id.au>2018-05-10 16:54:55 +0930
commit1b77f28e124add7505dbfbe863e9c5c0c6364aee (patch)
tree57d5e9923c03d7608ccf725245e675902da32f98 /meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi
parent4c99b9df640bbbb283264cc3d243c44e97867f13 (diff)
downloadtalos-openbmc-1b77f28e124add7505dbfbe863e9c5c0c6364aee.tar.gz
talos-openbmc-1b77f28e124add7505dbfbe863e9c5c0c6364aee.zip
phosphor-ipmi-host: Move configuration to phosphor-ipmi-config
Witherspoon requires an dev_id.json file whose content is partially derived from data provided by the os-release package. os-release is updated for each commit, as some of its content (VERSION and VERSION_ID) can be derived from `git describe`. As dev_id.json was provided by the phosphor-ipmi-host package, every commit transitively triggered a rebuild of phosphor-ipmi-host in order to satisfy Witherspoon's requirements. Always rebuilding phosphor-ipmi-host is unhelpful for several reasons: * It needlessly reduces CI throughput, as it is likely the commits in question do not modify the phosphor-ipmi-host package. * GCC suffers from what appears to be an unfixable[1] bug[2] that causes phoshor-ipmi-host to consume large (>5GiB) amounts of RAM when compiling some (at least Witherspoon) sensor configurations. To avoid this, separate the configuration files out into virtual/phosphor-ipmi-config and phosphor-ipmi-config packages that phosphor-ipmi-host RDEPENDS on. Witherspoon provides an alternative implementation in witherspoon-ipmi-config to mangle dev_id.json to its particular requirements. A virtual is used rather than a simple bbappends for Witherspoon, as the bbappend approach breaks builds of machines other than Witherspoon if Witherspoon is built first: The Witherspoon-specific dev_id.json file is deployed in its mangled form into e.g. a Zaius image. Specifically, the following sequence will trigger the issue: $ TEMPLATECONF=.../witherspoon.conf . openbmc-env $ bitbake obmc-phosphor-image $ rm -rf conf $ TEMPLATECONF=.../zaius.conf . openbmc-env $ bitbake obmc-phosphor-image [1] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290#c26 [2] https://gcc.gnu.org/bugzilla/show_bug.cgi?id=80290 Change-Id: Ib9629fc77b29e2deeab3f1c3a145d9e966c14ec4 Signed-off-by: Andrew Jeffery <andrew@aj.id.au>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend52
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb82
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json (renamed from meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/cipher_list.json)0
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json17
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json (renamed from meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dcmi_sensors.json)0
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json (renamed from meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dev_id.json)0
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json (renamed from meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json)0
7 files changed, 103 insertions, 48 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
index 27678bf88..748fa73f5 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host.bbappend
@@ -1,49 +1,5 @@
FILESEXTRAPATHS_append_witherspoon := ":${THISDIR}/${PN}"
-SRC_URI_append_witherspoon = " file://occ_sensors.hardcoded.yaml \
- file://dev_id.json \
- file://dcmi_sensors.json \
- file://power_reading.json \
- file://hwmon_sensors.hardcoded.yaml \
- file://cipher_list.json \
- "
-inherit image_version
-
-# Calculate the auxiliary firmware revision to be updated in the dev_id.json
-# file. It is calculated from the VERSION_ID field which currently has two
-# formats. The revision field is 4 bytes, the first two bytes represent the
-# count of commits from the tagging and next two bytes represent the version.
-# Both fields are represented in BCD encoded format, so 9999 is the maximum
-# value both fields can take. With the format "v2.1-216-ga78ace8", Petitboot
-# would display the firmware revision as "Firmware version: 2.01.02160000",
-# "0216" is count and the revision is "0000". With the format
-# "ibm-v2.0-10-r41-0-gd0c319e" Petitboot would display the firmware revision
-# as "Firmware version: 2.00.00100041", "0010" is count and the revision
-# is "0041".
-
-python do_populate_aux_version() {
- import json
- import re
- version_id = do_get_version(d)
-
- # count from the commit version
- count = re.findall("-(\d{1,4})-", version_id)
-
- release = re.findall("-r(\d{1,4})", version_id)
- if release:
- auxVer = count[0] + "{0:0>4}".format(release[0])
- else:
- auxVer = count[0] + "0000"
-
- # Update dev_id.json with the auxiliary firmware revision
- workdir = d.getVar('WORKDIR', True)
- file = os.path.join(workdir, 'dev_id.json')
-
- with open(file, "r+") as jsonFile:
- data = json.load(jsonFile)
- jsonFile.seek(0)
- jsonFile.truncate()
- data["aux"] = int(auxVer, 16)
- json.dump(data, jsonFile)
-}
-
-addtask populate_aux_version after do_configure before do_compile
+SRC_URI_append_witherspoon = " \
+ file://occ_sensors.hardcoded.yaml \
+ file://hwmon_sensors.hardcoded.yaml \
+ "
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
new file mode 100644
index 000000000..8ab47c631
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
@@ -0,0 +1,82 @@
+SUMMARY = "Witherspoon IPMI daemon configuration"
+PR = "r1"
+
+inherit obmc-phosphor-license
+inherit allarch
+
+SRC_URI = " \
+ file://cipher_list.json \
+ file://dcmi_cap.json \
+ file://dcmi_sensors.json \
+ file://dev_id.json \
+ file://power_reading.json \
+ "
+
+FILES_${PN} = " \
+ ${datadir}/ipmi-providers/cipher_list.json \
+ ${datadir}/ipmi-providers/dcmi_cap.json \
+ ${datadir}/ipmi-providers/dcmi_sensors.json \
+ ${datadir}/ipmi-providers/dev_id.json \
+ ${datadir}/ipmi-providers/power_reading.json \
+ "
+
+do_fetch[noexec] = "1"
+do_configure[noexec] = "1"
+do_compile[noexec] = "1"
+
+# Calculate the auxiliary firmware revision to be updated in the dev_id.json
+# file. It is calculated from the VERSION_ID field which currently has two
+# formats. The revision field is 4 bytes, the first two bytes represent the
+# count of commits from the tagging and next two bytes represent the version.
+# Both fields are represented in BCD encoded format, so 9999 is the maximum
+# value both fields can take. With the format "v2.1-216-ga78ace8", Petitboot
+# would display the firmware revision as "Firmware version: 2.01.02160000",
+# "0216" is count and the revision is "0000". With the format
+# "ibm-v2.0-10-r41-0-gd0c319e" Petitboot would display the firmware revision
+# as "Firmware version: 2.00.00100041", "0010" is count and the revision
+# is "0041".
+
+inherit image_version
+
+do_patch[depends] = "os-release:do_populate_sysroot"
+
+python do_patch() {
+ import json
+ import re
+ from shutil import copyfile
+ version_id = do_get_version(d)
+
+ # count from the commit version
+ count = re.findall("-(\d{1,4})-", version_id)
+
+ release = re.findall("-r(\d{1,4})", version_id)
+ if release:
+ auxVer = count[0] + "{0:0>4}".format(release[0])
+ else:
+ auxVer = count[0] + "0000"
+
+ workdir = d.getVar('WORKDIR', True)
+ file = os.path.join(workdir, 'dev_id.json')
+
+ # Update dev_id.json with the auxiliary firmware revision
+ with open(file, "r+") as jsonFile:
+ data = json.load(jsonFile)
+ jsonFile.seek(0)
+ jsonFile.truncate()
+ data["aux"] = int(auxVer, 16)
+ json.dump(data, jsonFile)
+}
+
+do_install() {
+ install -d ${D}${datadir}/ipmi-providers
+ install -m 0644 -D ${WORKDIR}/cipher_list.json \
+ ${D}${datadir}/ipmi-providers/cipher_list.json
+ install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
+ ${D}${datadir}/ipmi-providers/dcmi_cap.json
+ install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
+ ${D}${datadir}/ipmi-providers/dcmi_sensors.json
+ install -m 0644 -D ${WORKDIR}/dev_id.json \
+ ${D}${datadir}/ipmi-providers/dev_id.json
+ install -m 0644 -D ${WORKDIR}/power_reading.json \
+ ${D}${datadir}/ipmi-providers/power_reading.json
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/cipher_list.json b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json
index 0f13b1e73..0f13b1e73 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/cipher_list.json
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json
new file mode 100644
index 000000000..2d8832081
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json
@@ -0,0 +1,17 @@
+{
+ "PowerManagement": 1,
+ "OOBSecondaryLan": 0,
+ "SerialTMODE": 0,
+ "InBandSystemInterfaceChannel": 1,
+ "SELAutoRollOver": 1,
+ "FlushEntireSELUponRollOver": 0,
+ "RecordLevelSELFlushUponRollOver": 0,
+ "NumberOfSELEntries": 200,
+ "TempMonitoringSamplingFreq":0,
+ "PowerMgmtDeviceSlaveAddress": 0,
+ "BMCChannelNumber": 0,
+ "DeviceRivision": 0,
+ "MandatoryPrimaryLanOOBSupport": 1,
+ "OptionalSecondaryLanOOBSupport": 255,
+ "OptionalSerialOOBMTMODECapability": 255
+}
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dcmi_sensors.json b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json
index 837071398..837071398 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dcmi_sensors.json
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dev_id.json b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json
index 6cd9a94b3..6cd9a94b3 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/dev_id.json
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json
index 97e8f32b5..97e8f32b5 100644
--- a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-host/power_reading.json
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json
OpenPOWER on IntegriCloud