summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-01-28 13:00:52 -0500
committerPatrick Williams <patrick@stwcx.xyz>2017-02-02 13:44:28 +0000
commit2f63e8c040e2b7149585697d24d2bd6dc37f651a (patch)
tree824fe3ce8b4b9f7f5e9ae0b045f5f5d03665f732 /meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
parent0a544b5f874e81a1c4579d3de113c176668b6c80 (diff)
downloadtalos-openbmc-2f63e8c040e2b7149585697d24d2bd6dc37f651a.tar.gz
talos-openbmc-2f63e8c040e2b7149585697d24d2bd6dc37f651a.zip
ipmi: Remove virtual/phosphor-ipmi-fru-config
Replace this virtual with two others: -virtual/phosphor-ipmi-fru-hostfw-config -virtual/phosphor-ipmi-fru-inventory. Update ipmi-fru-parser machine recipes to provide virtual/phosphor-ipmi-fru-inventory rather than virtual/phosphor-ipmi-fru-config. Remove machine recipes on machines that use MRW since a single MRW recipe provides for any MRW using system automatically. Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com? Change-Id: Ia0d94b938eb2c7bfadd5a018ae5ea136f14dd874
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb')
-rw-r--r--meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb22
1 files changed, 22 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
new file mode 100644
index 000000000..90276695b
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/meta-ibm/meta-firestone/recipes-phosphor/ipmi/firestone-ipmi-inventory-map-native.bb
@@ -0,0 +1,22 @@
+SUMMARY = "Firestone IPMI to DBus Inventory mapping."
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-license
+inherit phosphor-ipmi-fru
+
+SRC_URI += "file://config.yaml"
+
+PROVIDES += "virtual/phosphor-ipmi-fru-inventory"
+
+S = "${WORKDIR}"
+
+do_install() {
+ # TODO: install this to inventory_datadir
+ # after ipmi-fru-parser untangles the host
+ # firmware config from the machine inventory.
+ DEST=${D}${config_datadir}
+
+ install -d ${DEST}
+ install config.yaml ${DEST}
+}
OpenPOWER on IntegriCloud