summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common
diff options
context:
space:
mode:
authorJoel Stanley <joel@jms.id.au>2016-10-31 15:40:39 +1030
committerPatrick Williams <patrick@stwcx.xyz>2016-11-04 09:17:41 -0500
commite7b0fd568ae25183397d3f51cd98c439c683f943 (patch)
treed2a4adb5b4a450f4ec5e95b133d4ed329097f461 /meta-openbmc-machines/meta-openpower/common
parent956c5d638d6f7b2d9a1dcfe549b417ef771705ba (diff)
downloadtalos-openbmc-e7b0fd568ae25183397d3f51cd98c439c683f943.tar.gz
talos-openbmc-e7b0fd568ae25183397d3f51cd98c439c683f943.zip
Switch userspace to use MTD access by default
Currently pflash defaults to using the MMIO interface through /dev/mem. We want to disable /dev/mem in production systems in the near future, so all non-debugging uses of it need to be eliminated. The new version of pflash defaults to MTD access. It also brings some API cleanups to libflash. We recently moved flasher to use MTD. This updates skeleton to pull in an update to flasher so that it can build against the new libflash API. Fixes: openbmc/openbmc#713 Change-Id: I6bde91c7df5d0588fc48dd2e847f21f0624a6950 Signed-off-by: Joel Stanley <joel@jms.id.au> Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc6
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0002-external-Utilize-DESTDIR-in-shared-makefile.patch39
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0003-gard-Fix-Makefile-race-condition.patch43
3 files changed, 2 insertions, 86 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc
index 941f86c67..248e13f7f 100644
--- a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc
@@ -3,15 +3,13 @@ LICENSE = "Apache-2.0"
SRC_URI += "git://github.com/open-power/skiboot.git;nobranch=1"
SRC_URI += "file://0001-external-Use-more-standard-PREFIX-vs-prefix.patch"
-SRC_URI += "file://0002-external-Utilize-DESTDIR-in-shared-makefile.patch"
-SRC_URI += "file://0003-gard-Fix-Makefile-race-condition.patch"
FILESEXTRAPATHS_append := "${THISDIR}/skiboot:"
LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
-SRCREV = "skiboot-5.3.5"
-PV = "5.3.5"
+SRCREV = "skiboot-5.4.0-rc3"
+PV = "5.4.0-rc3"
S = "${WORKDIR}/git"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0002-external-Utilize-DESTDIR-in-shared-makefile.patch b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0002-external-Utilize-DESTDIR-in-shared-makefile.patch
deleted file mode 100644
index 89ee54a75..000000000
--- a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0002-external-Utilize-DESTDIR-in-shared-makefile.patch
+++ /dev/null
@@ -1,39 +0,0 @@
-From 6c5cf9f87a9047bc56ccd8b6096b8ec4a6af96ab Mon Sep 17 00:00:00 2001
-From: Patrick Williams <patrick@stwcx.xyz>
-Date: Fri, 5 Aug 2016 16:53:21 -0500
-Subject: [PATCH 2/2] external: Utilize DESTDIR in shared makefile
-
-Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
----
- external/shared/Makefile | 12 ++++++------
- 1 file changed, 6 insertions(+), 6 deletions(-)
-
-diff --git a/external/shared/Makefile b/external/shared/Makefile
-index e0b3ff3..4baa6b4 100644
---- a/external/shared/Makefile
-+++ b/external/shared/Makefile
-@@ -39,15 +39,15 @@ all: links arch_links $(OBJS)
- $(CC) -shared -Wl,-soname,libflash.so -o $(SHARED_NAME) $(OBJS)
-
- install-lib: all
-- install -D -m 0755 $(SHARED_NAME) $(LIBDIR)/$(SHARED_NAME)
-- ln -sf $(SHARED_NAME) $(LIBDIR)/libflash.so
-+ install -D -m 0755 $(SHARED_NAME) $(DESTDIR)$(LIBDIR)/$(SHARED_NAME)
-+ ln -sf $(SHARED_NAME) $(DESTDIR)$(LIBDIR)/libflash.so
-
- install-dev: links arch_links
-- mkdir -p $(INCDIR)
-- install -m 0644 $(LIBFLASH_H) $(ARCHFLASH_H) $(INCDIR)
-+ mkdir -p $(DESTDIR)$(INCDIR)
-+ install -m 0644 $(LIBFLASH_H) $(ARCHFLASH_H) $(DESTDIR)$(INCDIR)
-
- install: install-lib install-dev
-
- uninstall:
-- rm -f $(LIBDIR)/libflash*
-- rm -rf $(INCDIR)
-+ rm -f $(DESTDIR)$(LIBDIR)/libflash*
-+ rm -rf $(DESTDIR)$(INCDIR)
---
-2.9.0
-
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0003-gard-Fix-Makefile-race-condition.patch b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0003-gard-Fix-Makefile-race-condition.patch
deleted file mode 100644
index 703874ec0..000000000
--- a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot/0003-gard-Fix-Makefile-race-condition.patch
+++ /dev/null
@@ -1,43 +0,0 @@
-From 7355feb27c79c406cc57e03da29e8f7a28f38c7e Mon Sep 17 00:00:00 2001
-From: Patrick Williams <patrick@stwcx.xyz>
-Date: Fri, 16 Sep 2016 15:41:02 -0500
-Subject: [PATCH] gard: Fix Makefile race condition
-
-Commit fd599965 added some dependencies in 'external/pflash'
-for libflash files that are created via symlink. Replicate
-that same behavior in 'external/gard' to prevent race conditions
-where we attempt to compile files from libflash before they are
-symlink'd.
-
-Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
----
- external/gard/rules.mk | 6 +++++-
- 1 file changed, 5 insertions(+), 1 deletion(-)
-
-diff --git a/external/gard/rules.mk b/external/gard/rules.mk
-index dfe93d5..3a7f6d9 100644
---- a/external/gard/rules.mk
-+++ b/external/gard/rules.mk
-@@ -2,7 +2,9 @@
-
- override CFLAGS += -O2 -Wall -Werror -I.
- OBJS = version.o gard.o
--LIBFLASH_OBJS += libflash-file.o libflash-libflash.o libflash-libffs.o libflash-ecc.o libflash-blocklevel.o
-+LIBFLASH_FILES := libflash.c libffs.c ecc.c blocklevel.c file.c
-+LIBFLASH_OBJS := $(addprefix libflash-, $(LIBFLASH_FILES:.c=.o))
-+LIBFLASH_SRC := $(addprefix libflash/,$(LIBFLASH_FILES))
- OBJS += $(LIBFLASH_OBJS)
- OBJS += common-arch_flash.o
- EXE = gard
-@@ -24,6 +26,8 @@ version.c: make_version.sh .version
- %.o : %.c
- $(CC) $(CFLAGS) -c $< -o $@
-
-+$(LIBFLASH_SRC): | links
-+
- $(LIBFLASH_OBJS): libflash-%.o : libflash/%.c
- $(CC) $(CFLAGS) -c $< -o $@
-
---
-2.7.3
-
OpenPOWER on IntegriCloud