summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot
diff options
context:
space:
mode:
authorPatrick Williams <patrick@stwcx.xyz>2016-08-05 15:42:22 -0500
committerPatrick Williams <patrick@stwcx.xyz>2016-08-10 17:55:11 +0000
commit5a844b1aef6a3c02c9a965237d80d1196447ba4f (patch)
tree5dbecd67e31a13deae5e578c19778c99ccf0dfad /meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot
parent3406e4a1f2b73ea0baed5389187a58001f732c8b (diff)
downloadtalos-openbmc-5a844b1aef6a3c02c9a965237d80d1196447ba4f.tar.gz
talos-openbmc-5a844b1aef6a3c02c9a965237d80d1196447ba4f.zip
pflash: Refactor recipe
Move pflash to a general skiboot recipe so that we can create additional recipes for other components of skiboot. Change-Id: I59253d17840da7a07f00bec9c650676da9ffb5e5 Signed-off-by: Patrick Williams <patrick@stwcx.xyz>
Diffstat (limited to 'meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot')
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/pflash.bb5
-rw-r--r--meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc25
2 files changed, 30 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/pflash.bb b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/pflash.bb
new file mode 100644
index 000000000..70852669b
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/pflash.bb
@@ -0,0 +1,5 @@
+SUMMARY = "pflash programmer for OpenPower"
+DESCRIPTION = "pflash firmware programming tool for OpenPower machines"
+
+require skiboot.inc
+EXTRA_OEMAKE_append = " PFLASH_VERSION=${PV} LINKAGE=dynamic"
diff --git a/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc
new file mode 100644
index 000000000..757d63d5a
--- /dev/null
+++ b/meta-openbmc-machines/meta-openpower/common/recipes-bsp/skiboot/skiboot.inc
@@ -0,0 +1,25 @@
+HOMEPAGE = "https://github.com/open-power"
+LICENSE = "Apache-2.0"
+
+SRC_URI += "git://github.com/open-power/skiboot.git"
+
+LIC_FILES_CHKSUM = "file://${S}/LICENCE;md5=3b83ef96387f14655fc854ddc3c6bd57"
+
+SRCREV = "skiboot-5.3.0"
+PV = "5.3.0"
+
+S = "${WORKDIR}/git"
+
+EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX} SKIBOOT_VERSION=${PV} V=1"
+
+SKIBOOT_SUBDIR ?= "external/${PN}"
+
+do_compile() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} all
+}
+
+do_install() {
+ oe_runmake -C ${SKIBOOT_SUBDIR} install DESTDIR=${D} PREFIX=${D}/usr
+}
+
+BBCLASSEXTEND = "native nativesdk"
OpenPOWER on IntegriCloud