summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor
diff options
context:
space:
mode:
authorKen Chen <chen.kenyy@inventec.com>2018-02-12 10:28:04 +0800
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-02-27 14:07:31 +0000
commit6288c9cfaef0a449606f3790d3e5bf17fdec1d1c (patch)
tree5e6971fb6636a413886d4baf5fff9ba3d2796862 /meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor
parentcb3263ad71eb86a329d530be0542a6c7096d9871 (diff)
downloadtalos-openbmc-6288c9cfaef0a449606f3790d3e5bf17fdec1d1c.tar.gz
talos-openbmc-6288c9cfaef0a449606f3790d3e5bf17fdec1d1c.zip
Add obmc-console conf
Config UART2 to obmc-console source Use script to control UART Mux Change-Id: I73d5165e497c7af1bc445ae8d365deb49b1f508d Signed-off-by: Ken Chen <chen.kenyy@inventec.com>
Diffstat (limited to 'meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor')
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client.bb10
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client.sh7
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client@.service9
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console.bbappend2
-rw-r--r--meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console/obmc-console.conf2
5 files changed, 30 insertions, 0 deletions
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client.bb b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client.bb
new file mode 100644
index 000000000..4c8dc153f
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client.bb
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_centriq2400-rep := "${THISDIR}/${PN}:"
+inherit obmc-phosphor-license
+
+SRC_URI += "file://centriq-2400rep-console-client.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/centriq-2400rep-console-client.sh ${D}${bindir}/centriq-2400rep-console-client.sh
+}
+
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client.sh b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client.sh
new file mode 100644
index 000000000..3ecd0f819
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client.sh
@@ -0,0 +1,7 @@
+#!/bin/sh -e
+#Control UART mux for obmc-console-client
+echo 0 > /sys/class/gpio/gpio325/value
+obmc-console-client
+echo 1 > /sys/class/gpio/gpio325/value
+
+
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client@.service b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client@.service
new file mode 100644
index 000000000..81d3bfe6a
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/centriq-2400rep-console-client/centriq-2400rep-console-client@.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Control UART mux for obmc-console-client
+
+[Service]
+ExecStart=/usr/bin/env centriq-2400rep-console-client.sh
+SyslogIdentifier=centriq-2400rep-console-client.sh
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console.bbappend b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console.bbappend
new file mode 100644
index 000000000..101fe6489
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend_centriq2400-rep := "${THISDIR}/${PN}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS2"
diff --git a/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 000000000..85f35c190
--- /dev/null
+++ b/meta-openbmc-machines/meta-arm/meta-qualcomm/meta-centriq2400-rep/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,2 @@
+local-tty = ttyS2
+local-tty-baud = 115200
OpenPOWER on IntegriCloud