summaryrefslogtreecommitdiffstats
path: root/meta-openbmc-bsp
diff options
context:
space:
mode:
authorBenjamin Fair <benjaminfair@google.com>2018-06-20 14:57:10 -0700
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-07-16 03:53:34 +0000
commita6ac4f9c0b4e7561631ed835c8e044a4ad6a3ac2 (patch)
tree27d6d62a57ad8da0bd9eb624d105f09fc92d8073 /meta-openbmc-bsp
parentd2aeec0642ffd0ed5b7372ae1d08e272418462b9 (diff)
downloadtalos-openbmc-a6ac4f9c0b4e7561631ed835c8e044a4ad6a3ac2.tar.gz
talos-openbmc-a6ac4f9c0b4e7561631ed835c8e044a4ad6a3ac2.zip
npcm7xx: kernel: replace linux-obmc with linux-nuvoton
The linux-obmc recipe has been removed and BSPs are expected to provide their own Linux recipes now. This updates the Nuvoton BSP to include its own Linux recipe so it can build successfully again. Change-Id: I61e0cf0745be6ae4e282b32abf36aad4c5f4b860 Signed-off-by: Benjamin Fair <benjaminfair@google.com>
Diffstat (limited to 'meta-openbmc-bsp')
-rw-r--r--meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/conf/machine/include/npcm7xx.inc4
-rw-r--r--meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton.inc21
-rw-r--r--meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton/defconfig (renamed from meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc/defconfig)0
-rw-r--r--meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton_git.bb6
-rw-r--r--meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc_%.bbappend2
5 files changed, 29 insertions, 4 deletions
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/conf/machine/include/npcm7xx.inc b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/conf/machine/include/npcm7xx.inc
index c48b30820..e2fd2608c 100644
--- a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/conf/machine/include/npcm7xx.inc
+++ b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/conf/machine/include/npcm7xx.inc
@@ -2,11 +2,11 @@
#@NAME: Nuvoton NPCM7XX
#@DESCRIPTION: Common machine configuration for Nuvoton NPCM7XX Chip
-PREFERRED_PROVIDER_virtual/kernel ?= "linux-obmc"
-
+PREFERRED_PROVIDER_virtual/kernel ?= "linux-nuvoton"
KERNEL_IMAGETYPE ?= "uImage"
KERNEL_EXTRA_ARGS ?= "UIMAGE_LOADADDR=0x00008000"
+PREFERRED_PROVIDER_virtual/bootloader ?= "u-boot-nuvoton"
PREFERRED_PROVIDER_u-boot ?= "u-boot-nuvoton"
PREFERRED_PROVIDER_u-boot-fw-utils ?= "u-boot-fw-utils-nuvoton"
UBOOT_MACHINE ?= "PolegSVB_config"
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton.inc b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton.inc
new file mode 100644
index 000000000..5380478e8
--- /dev/null
+++ b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton.inc
@@ -0,0 +1,21 @@
+DESCRIPTION = "Linux kernel for Nuvoton NPCM7xx"
+SECTION = "kernel"
+LICENSE = "GPLv2"
+
+PROVIDES += "virtual/kernel"
+
+KCONFIG_MODE="--alldefconfig"
+
+KSRC ?= "git://github.com/openbmc/linux;protocol=git;branch=${KBRANCH}"
+SRC_URI = "${KSRC}"
+SRC_URI_append_npcm7xx = " file://defconfig"
+
+LINUX_VERSION_EXTENSION ?= "-${SRCREV}"
+
+PV = "${LINUX_VERSION}+git${SRCPV}"
+
+inherit kernel
+require recipes-kernel/linux/linux-yocto.inc
+
+# From 4.16+ the COPYING file changed
+LIC_FILES_CHKSUM = "file://COPYING;md5=bbea815ee2795b2f4230826c0c6b8814"
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc/defconfig b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton/defconfig
index 07e0f4ad1..07e0f4ad1 100644
--- a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc/defconfig
+++ b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton/defconfig
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton_git.bb b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton_git.bb
new file mode 100644
index 000000000..91d74379a
--- /dev/null
+++ b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-nuvoton_git.bb
@@ -0,0 +1,6 @@
+KBRANCH ?= "dev-4.17"
+LINUX_VERSION ?= "4.17.4"
+
+SRCREV="8fb9a0714f8ff91756a9746707c4f884b3745a40"
+
+require linux-nuvoton.inc
diff --git a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc_%.bbappend b/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc_%.bbappend
deleted file mode 100644
index e59c10993..000000000
--- a/meta-openbmc-bsp/meta-nuvoton/meta-npcm7xx/recipes-kernel/linux/linux-obmc_%.bbappend
+++ /dev/null
@@ -1,2 +0,0 @@
-FILESEXTRAPATHS_prepend_npcm7xx := "${THISDIR}/${PN}:"
-SRC_URI_append_npcm7xx = " file://defconfig"
OpenPOWER on IntegriCloud