summaryrefslogtreecommitdiffstats
path: root/meta-inventec
diff options
context:
space:
mode:
authorMatt Spinler <spinler@us.ibm.com>2018-08-08 10:59:48 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-28 18:26:32 -0400
commit808fe4cc85098576dc65a8a465f49024700ff431 (patch)
treeebf265b4de277f57094c1d7ce080ab22ef9e5fcd /meta-inventec
parent2d8fc1140654b7d97a4e6806ab1617a34c2a7f70 (diff)
downloadtalos-openbmc-808fe4cc85098576dc65a8a465f49024700ff431.tar.gz
talos-openbmc-808fe4cc85098576dc65a8a465f49024700ff431.zip
Add Lanyang GPIO JSON
These GPIOs are used by the code in the skeleton repo. (From meta-inventec rev: 6abf0600f408fc66d182e829c60a3ea807e49ffa) Change-Id: Ia0e3b5ddf720163b039c0b5d70f23b83833e4d93 Signed-off-by: Matt Spinler <spinler@us.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-inventec')
-rw-r--r--meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json78
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..0bb36c66b
--- /dev/null
+++ b/meta-inventec/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,78 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "SYS_PWROK_BUFF",
+ "latch_out": "BMC_UCD_LATCH_LE",
+ "power_up_outs": [
+ {"name": "SOFTWARE_PGOOD", "polarity": true},
+ {"name": "BMC_POWER_UP", "polarity": false}
+ ],
+ "reset_outs": [
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "SOFTWARE_PGOOD",
+ "pin": "M6",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_POWER_UP",
+ "pin": "E2",
+ "direction": "out"
+ },
+ {
+ "name": "SYS_PWROK_BUFF",
+ "pin": "F6",
+ "direction": "in"
+ },
+ {
+ "name": "PHY_RST_N",
+ "pin": "D6",
+ "direction": "out"
+ },
+ {
+ "name": "HDD_PWR_EN",
+ "pin": "B0",
+ "direction": "out"
+ },
+ {
+ "name": "CP0_DEVICES_RESET_N",
+ "pin": "AA6",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_CP0_PERST_ENABLE",
+ "pin": "H3",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_UCD_LATCH_LE",
+ "pin": "P4",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E4",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "E3",
+ "direction": "both"
+ },
+ {
+ "name": "PE_MEZZB_PRSNT_N",
+ "pin": "P6",
+ "direction": "in"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "F3",
+ "direction": "falling"
+ }
+ ]
+}
OpenPOWER on IntegriCloud