summaryrefslogtreecommitdiffstats
path: root/meta-inventec/meta-lanyang/recipes-phosphor
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-04 16:58:54 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-06 13:51:28 -0400
commit134b6d49de68990ff80b297e3cb627dc168a497e (patch)
treeb729047c3fce6f457940e49cbbd065be9de3c10c /meta-inventec/meta-lanyang/recipes-phosphor
parente5b84457e9cb060f8bd5654177d91eb1034adf8f (diff)
downloadtalos-openbmc-134b6d49de68990ff80b297e3cb627dc168a497e.tar.gz
talos-openbmc-134b6d49de68990ff80b297e3cb627dc168a497e.zip
skeleton: lanyang: fix broken gpio config path
9d47808f7e1 erroneously introduced some new files in a meta-inventec subdirectory. Move the files to the correct location. This can likely be blamed on the recent move to poky-style subtrees as 9d47808f7e1 was originally submitted to the old, pre-subtree openbmc project repository. (From meta-inventec rev: 175ad32bef1bc0664bc815020b8827cb849ad545) Change-Id: If4a2ff56bfda9d92772916314cad7dbe828fb9c7 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-inventec/meta-lanyang/recipes-phosphor')
-rw-r--r--meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend1
-rw-r--r--meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json78
2 files changed, 79 insertions, 0 deletions
diff --git a/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend b/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
new file mode 100644
index 000000000..72d991c7e
--- /dev/null
+++ b/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf.bbappend
@@ -0,0 +1 @@
+FILESEXTRAPATHS_prepend := "${THISDIR}/${PN}:"
diff --git a/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json b/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
new file mode 100644
index 000000000..0bb36c66b
--- /dev/null
+++ b/meta-inventec/meta-lanyang/recipes-phosphor/skeleton/obmc-libobmc-intf/gpio_defs.json
@@ -0,0 +1,78 @@
+{
+ "gpio_configs": {
+
+ "power_config": {
+ "power_good_in": "SYS_PWROK_BUFF",
+ "latch_out": "BMC_UCD_LATCH_LE",
+ "power_up_outs": [
+ {"name": "SOFTWARE_PGOOD", "polarity": true},
+ {"name": "BMC_POWER_UP", "polarity": false}
+ ],
+ "reset_outs": [
+ ]
+ }
+ },
+
+ "gpio_definitions": [
+ {
+ "name": "SOFTWARE_PGOOD",
+ "pin": "M6",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_POWER_UP",
+ "pin": "E2",
+ "direction": "out"
+ },
+ {
+ "name": "SYS_PWROK_BUFF",
+ "pin": "F6",
+ "direction": "in"
+ },
+ {
+ "name": "PHY_RST_N",
+ "pin": "D6",
+ "direction": "out"
+ },
+ {
+ "name": "HDD_PWR_EN",
+ "pin": "B0",
+ "direction": "out"
+ },
+ {
+ "name": "CP0_DEVICES_RESET_N",
+ "pin": "AA6",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_CP0_PERST_ENABLE",
+ "pin": "H3",
+ "direction": "out"
+ },
+ {
+ "name": "BMC_UCD_LATCH_LE",
+ "pin": "P4",
+ "direction": "out"
+ },
+ {
+ "name": "POWER_BUTTON",
+ "pin": "E4",
+ "direction": "both"
+ },
+ {
+ "name": "RESET_BUTTON",
+ "pin": "E3",
+ "direction": "both"
+ },
+ {
+ "name": "PE_MEZZB_PRSNT_N",
+ "pin": "P6",
+ "direction": "in"
+ },
+ {
+ "name": "CHECKSTOP",
+ "pin": "F3",
+ "direction": "falling"
+ }
+ ]
+}
OpenPOWER on IntegriCloud