summaryrefslogtreecommitdiffstats
path: root/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
diff options
context:
space:
mode:
authorJames Feist <james.feist@linux.intel.com>2019-02-14 10:11:18 -0800
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-02-14 20:15:51 -0500
commit073a600a0ad7848d4d846269181a777779413566 (patch)
tree6f67123a91b9499c688248c5353e1888465f4119 /meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
parent71e7d2082d73ba89d01d59a8de8e5b1f3fad6205 (diff)
downloadtalos-openbmc-073a600a0ad7848d4d846269181a777779413566.tar.gz
talos-openbmc-073a600a0ad7848d4d846269181a777779413566.zip
Fix build
Add missing components, this along with https://gerrit.openbmc-project.xyz/#/c/openbmc/x86-power-control/+/18388/ will allow s2600wf to build again. Tested-by: it built (From meta-intel rev: 53b9232f7d65f955150f304b2261c9dd5d0a1a9f) Change-Id: I936f2739ded247a712ca78c40034ab2964ee8871 Signed-off-by: James Feist <james.feist@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb')
-rw-r--r--meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb19
1 files changed, 19 insertions, 0 deletions
diff --git a/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
new file mode 100644
index 000000000..8ef3a5dfa
--- /dev/null
+++ b/meta-intel/meta-common/recipes-phosphor/leds/intel-led-manager-config-native.bb
@@ -0,0 +1,19 @@
+SUMMARY = "Phosphor LED Group Management for Intel"
+PR = "r1"
+
+inherit native
+inherit obmc-phosphor-utils
+
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${INTELBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+PROVIDES += "virtual/phosphor-led-manager-config-native"
+
+SRC_URI += "file://led.yaml"
+S = "${WORKDIR}"
+
+do_install() {
+ SRC=${S}
+ DEST=${D}${datadir}/phosphor-led-manager
+ install -D ${SRC}/led.yaml ${DEST}/led.yaml
+}
OpenPOWER on IntegriCloud