summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-22 21:21:30 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2019-03-26 16:46:35 -0400
commitb078bcfa6dbe55957b046c7d22b8c0cf7fee6850 (patch)
treeb78021f8711ba8ada79c67f821da66c4be8ff773 /meta-ibm
parentad06047d8c4db62a3d1b4af6a32bb11c2c7147ce (diff)
downloadtalos-openbmc-b078bcfa6dbe55957b046c7d22b8c0cf7fee6850.tar.gz
talos-openbmc-b078bcfa6dbe55957b046c7d22b8c0cf7fee6850.zip
meta-ibm: Fix explicit dependencies antipattern
Out of the box bitbake examines built applications, automatically adds runtime dependencies and thus ensures any library packages dependencies are automatically added to images, sdks, etc. There is no need to list them explicitly in a recipe. Dependencies change over time, and listing them explicitly is likely prone to errors - the net effect being unnecessary shared library packages being installed into images. Consult https://www.yoctoproject.org/docs/latest/mega-manual/mega-manual.html#var-RDEPENDS for information on when to use explicit runtime dependencies. (From meta-ibm rev: fa99caa61ecd28325e9070f268a51a5b52363bc4) Change-Id: Icc97d4b33635caf127a17e70ba6c23f1367eb735 Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend2
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb6
-rw-r--r--meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb6
3 files changed, 0 insertions, 14 deletions
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
index 8cc310e7c..c70cbc8a3 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/fans/phosphor-fan_%.bbappend
@@ -7,8 +7,6 @@ FAN_PACKAGES += " \
PACKAGECONFIG += "cooling-type"
-RDEPENDS_phosphor-cooling-type += "libevdev"
-
TMPL_COOLING = "phosphor-cooling-type@.service"
INSTFMT_COOLING = "phosphor-cooling-type@{0}.service"
COOLING_TGT = "${SYSTEMD_DEFAULT_TARGET}"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
index c0de3e6f9..7f55ecf35 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/power/witherspoon-pfault-analysis_git.bb
@@ -20,12 +20,6 @@ DEPENDS += " \
sdeventplus \
"
-RDEPENDS_${PN} += " \
- phosphor-logging \
- phosphor-dbus-interfaces \
- sdbusplus \
- "
-
CHASSIS_ON_TGT = "obmc-chassis-poweron@0.target"
SEQ_MONITOR_SVC = "witherspoon-pseq-monitor.service"
SEQ_MONITOR_FMT = "../${SEQ_MONITOR_SVC}:${CHASSIS_ON_TGT}.wants/${SEQ_MONITOR_SVC}"
diff --git a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
index 389e46d40..2ca9d6745 100644
--- a/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
+++ b/meta-ibm/recipes-phosphor/logging/ibm-logging_git.bb
@@ -23,12 +23,6 @@ DEPENDS += " \
sdbusplus \
"
-RDEPENDS_${PN} += " \
- phosphor-logging \
- phosphor-dbus-interfaces \
- sdbusplus \
- "
-
S = "${WORKDIR}/git"
SRC_URI += "file://policyTable.json"
OpenPOWER on IntegriCloud