summaryrefslogtreecommitdiffstats
path: root/meta-ibm
diff options
context:
space:
mode:
authorTom Joseph <tomjoseph@in.ibm.com>2018-09-24 07:34:14 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-09-26 13:25:35 -0400
commit6c09f7a1614f67835e46c088cd2061e41d1e1903 (patch)
tree48c314c6cbb63124be082e92d00a016c75873953 /meta-ibm
parentfe3486b5fd44de0aa55fd76a088a6ae6263ffedc (diff)
downloadtalos-openbmc-6c09f7a1614f67835e46c088cd2061e41d1e1903.tar.gz
talos-openbmc-6c09f7a1614f67835e46c088cd2061e41d1e1903.zip
phosphor-ipmi-config: Refactor phosphor-ipmi-config provider
The phopshor-ipmi-config provider witherspoon-ipmi-config is removed to use the default configuration files. cipher_list.json and dcmi_cap.json for the witherspoon is the same as the default configuration file. dcmi_sensors.json, dev_id.json and power_reading.json is specific to witherspoon. do_patch populates the aux field in dev_id.json for witherspoon. (From meta-ibm rev: 5e794ec57243fd8aced04118d8f9fc90a5bbd3a4) Change-Id: Icd355780524b6104f89390dbe0017d2c667e963c Signed-off-by: Tom Joseph <tomjoseph@in.ibm.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm')
-rw-r--r--meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf5
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb)42
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dcmi_sensors.json (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dev_id.json (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/power_reading.json (renamed from meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json)0
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json38
-rw-r--r--meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json17
7 files changed, 2 insertions, 100 deletions
diff --git a/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf b/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
index 1ccd1cf5a..0b1776222 100644
--- a/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
+++ b/meta-ibm/meta-witherspoon/conf/machine/witherspoon.conf
@@ -19,9 +19,6 @@ PHOSPHOR_MRW_REV = "6ca015dbd3e1e9d5206f9ec13ec9db2d8965e181"
# Inhibit phosphor-hwmon-config-mrw
VIRTUAL-RUNTIME_phosphor-hwmon-config_df-mrw = ""
-# Pick up the Witherspoon-specific IPMI configuration
-VIRTUAL-RUNTIME_ipmi-config = "witherspoon-ipmi-config"
-
# Inhibit phosphor-fan-presence-mrw-native
PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
"phosphor-fan-presence-config-native"
@@ -29,5 +26,3 @@ PREFERRED_PROVIDER_virtual/phosphor-fan-presence-config_df-mrw = \
# Inhibit phosphor-fan-control-fan-config-mrw-native
PREFERRED_PROVIDER_virtual/phosphor-fan-control-fan-config_df-mrw = \
"phosphor-fan-control-fan-config-native"
-
-PREFERRED_RPROVIDER_virtual/phosphor-ipmi-config = "witherspoon-ipmi-config"
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
index 8ab47c631..8445c835a 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config.bb
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config.bbappend
@@ -1,28 +1,4 @@
-SUMMARY = "Witherspoon IPMI daemon configuration"
-PR = "r1"
-
-inherit obmc-phosphor-license
-inherit allarch
-
-SRC_URI = " \
- file://cipher_list.json \
- file://dcmi_cap.json \
- file://dcmi_sensors.json \
- file://dev_id.json \
- file://power_reading.json \
- "
-
-FILES_${PN} = " \
- ${datadir}/ipmi-providers/cipher_list.json \
- ${datadir}/ipmi-providers/dcmi_cap.json \
- ${datadir}/ipmi-providers/dcmi_sensors.json \
- ${datadir}/ipmi-providers/dev_id.json \
- ${datadir}/ipmi-providers/power_reading.json \
- "
-
-do_fetch[noexec] = "1"
-do_configure[noexec] = "1"
-do_compile[noexec] = "1"
+FILESEXTRAPATHS_prepend_witherspoon := "${THISDIR}/${PN}:"
# Calculate the auxiliary firmware revision to be updated in the dev_id.json
# file. It is calculated from the VERSION_ID field which currently has two
@@ -35,9 +11,9 @@ do_compile[noexec] = "1"
# "ibm-v2.0-10-r41-0-gd0c319e" Petitboot would display the firmware revision
# as "Firmware version: 2.00.00100041", "0010" is count and the revision
# is "0041".
-
inherit image_version
+unset do_patch[noexec]
do_patch[depends] = "os-release:do_populate_sysroot"
python do_patch() {
@@ -66,17 +42,3 @@ python do_patch() {
data["aux"] = int(auxVer, 16)
json.dump(data, jsonFile)
}
-
-do_install() {
- install -d ${D}${datadir}/ipmi-providers
- install -m 0644 -D ${WORKDIR}/cipher_list.json \
- ${D}${datadir}/ipmi-providers/cipher_list.json
- install -m 0644 -D ${WORKDIR}/dcmi_cap.json \
- ${D}${datadir}/ipmi-providers/dcmi_cap.json
- install -m 0644 -D ${WORKDIR}/dcmi_sensors.json \
- ${D}${datadir}/ipmi-providers/dcmi_sensors.json
- install -m 0644 -D ${WORKDIR}/dev_id.json \
- ${D}${datadir}/ipmi-providers/dev_id.json
- install -m 0644 -D ${WORKDIR}/power_reading.json \
- ${D}${datadir}/ipmi-providers/power_reading.json
-}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dcmi_sensors.json
index 837071398..837071398 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_sensors.json
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dcmi_sensors.json
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dev_id.json
index 6cd9a94b3..6cd9a94b3 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dev_id.json
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/dev_id.json
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/power_reading.json
index 97e8f32b5..97e8f32b5 100644
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/power_reading.json
+++ b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/phosphor-ipmi-config/power_reading.json
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json
deleted file mode 100644
index 0f13b1e73..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/cipher_list.json
+++ /dev/null
@@ -1,38 +0,0 @@
-{
- "a":{
- "cipher":1,
- "authentication":1,
- "integrity":0,
- "confidentiality":0
- },
- "b":{
- "cipher":2,
- "authentication":1,
- "integrity":1,
- "confidentiality":0
- },
- "c":{
- "cipher":3,
- "authentication":1,
- "integrity":1,
- "confidentiality":1
- },
- "d":{
- "cipher":15,
- "authentication":3,
- "integrity":0,
- "confidentiality":0
- },
- "e":{
- "cipher":16,
- "authentication":3,
- "integrity":4,
- "confidentiality":0
- },
- "f":{
- "cipher":17,
- "authentication":3,
- "integrity":4,
- "confidentiality":1
- }
-}
diff --git a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json b/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json
deleted file mode 100644
index 2d8832081..000000000
--- a/meta-ibm/meta-witherspoon/recipes-phosphor/ipmi/witherspoon-ipmi-config/dcmi_cap.json
+++ /dev/null
@@ -1,17 +0,0 @@
-{
- "PowerManagement": 1,
- "OOBSecondaryLan": 0,
- "SerialTMODE": 0,
- "InBandSystemInterfaceChannel": 1,
- "SELAutoRollOver": 1,
- "FlushEntireSELUponRollOver": 0,
- "RecordLevelSELFlushUponRollOver": 0,
- "NumberOfSELEntries": 200,
- "TempMonitoringSamplingFreq":0,
- "PowerMgmtDeviceSlaveAddress": 0,
- "BMCChannelNumber": 0,
- "DeviceRivision": 0,
- "MandatoryPrimaryLanOOBSupport": 1,
- "OptionalSecondaryLanOOBSupport": 255,
- "OptionalSerialOOBMTMODECapability": 255
-}
OpenPOWER on IntegriCloud