summaryrefslogtreecommitdiffstats
path: root/meta-ibm/recipes-phosphor/logging/ibm-logging.bb
diff options
context:
space:
mode:
authorDave Cobbley <david.j.cobbley@linux.intel.com>2018-08-22 21:40:54 -0400
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2018-08-23 12:39:42 -0400
commit194ff4f1f5d44b12e9cb06ddafa6adb20174a13c (patch)
tree823835cd29daf8901a31ac14c7e6534abf199be3 /meta-ibm/recipes-phosphor/logging/ibm-logging.bb
parent4feb727cd6b77a68bdaca63e121b378d814f5eaf (diff)
downloadtalos-openbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.tar.gz
talos-openbmc-194ff4f1f5d44b12e9cb06ddafa6adb20174a13c.zip
[Subtree] Bring openbmc machines to top level
The new subtree model brings the subtrees up from the openbmc-machines layer. Change-Id: I58a03ae1be374bc79ae1438e65e888375d12d0c0 Signed-off-by: Dave Cobbley <david.j.cobbley@linux.intel.com> Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'meta-ibm/recipes-phosphor/logging/ibm-logging.bb')
-rw-r--r--meta-ibm/recipes-phosphor/logging/ibm-logging.bb79
1 files changed, 79 insertions, 0 deletions
diff --git a/meta-ibm/recipes-phosphor/logging/ibm-logging.bb b/meta-ibm/recipes-phosphor/logging/ibm-logging.bb
new file mode 100644
index 000000000..e32678708
--- /dev/null
+++ b/meta-ibm/recipes-phosphor/logging/ibm-logging.bb
@@ -0,0 +1,79 @@
+SUMMARY = "IBM enhanced error logging"
+DESCRIPTION = "Adds additional error logging functionality for IBM systems"
+PR = "r1"
+HOMEPAGE = "https://github.com/openbmc/ibm-logging"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${S}/LICENSE;md5=86d3f3a95c324c9479bd8986968f4327"
+SRC_URI += "git://github.com/openbmc/ibm-logging"
+SRCREV = "34af47ff623ce077670d270693f36e4c51adfa10"
+
+inherit autotools
+inherit pkgconfig
+inherit pythonnative
+inherit obmc-phosphor-dbus-service
+inherit obmc-phosphor-systemd
+inherit phosphor-dbus-yaml
+
+DEPENDS += " \
+ ibm-dbus-interfaces \
+ phosphor-logging \
+ nlohmann-json \
+ autoconf-archive-native \
+ sdbusplus \
+ "
+
+RDEPENDS_${PN} += " \
+ phosphor-logging \
+ phosphor-dbus-interfaces \
+ sdbusplus \
+ "
+
+S = "${WORKDIR}/git"
+
+SRC_URI += "file://policyTable.json"
+
+PACKAGECONFIG ??= ""
+PACKAGECONFIG[policy-interface] = "--enable-policy-interface, --disable-policy-interface,,"
+
+SERVICE = "com.ibm.Logging.service"
+DBUS_SERVICE_${PN} += "${SERVICE}"
+
+#The link is so that this service will restart if phosphor-logging restarts.
+#The BindsTo in the service will not do the restart, it will only do the
+#original start and a stop.
+LOG_FMT = "../${SERVICE}:xyz.openbmc_project.Logging.service.wants/${SERVICE}"
+SYSTEMD_LINK_${PN} += "${LOG_FMT}"
+
+do_install_append(){
+
+ install -d ${D}${datadir}/ibm-logging
+
+ ${S}/condense_policy.py \
+ -p ${WORKDIR}/policyTable.json \
+ -c ${D}/${datadir}/ibm-logging/policy.json
+}
+
+#An optional task to generate a report on all of the errors
+#created by OpenBMC, and compare these errors to what is
+#in the error policy table
+do_report(){
+
+ ${S}/create_error_reports.py \
+ -p ${D}/${datadir}/ibm-logging/policy.json \
+ -y ${STAGING_DIR_NATIVE}${yaml_dir} \
+ -e ${WORKDIR}/build/all_errors.json \
+ -x ${WORKDIR}/build/policy_crosscheck.txt
+
+}
+
+addtask report
+
+#Collect all of the error YAML files into our recipe-sysroot-native dir.
+do_report[depends] = " \
+ ibm-logging:do_install \
+ phosphor-logging-error-logs-native:do_populate_sysroot \
+ phosphor-dbus-interfaces-native:do_populate_sysroot \
+ openpower-dbus-interfaces-native:do_populate_sysroot \
+ openpower-occ-control-native:do_populate_sysroot \
+ openpower-debug-collector-native:do_populate_sysroot \
+ "
OpenPOWER on IntegriCloud