summaryrefslogtreecommitdiffstats
path: root/meta-hxt
diff options
context:
space:
mode:
authorYuan Yao <yao.yuan@hxt-semitech.com>2018-12-07 18:10:04 +0800
committerAndrew Geissler <geissonator@yahoo.com>2019-03-12 08:13:58 -0500
commit88e7a15a69c32ee7d040216c585291670f3b98b4 (patch)
treeaf2627a432b80f5245279264ef2ec086bb258418 /meta-hxt
parentc13f46e1deabb6ba19e818ce5050ccfbebc6d070 (diff)
downloadtalos-openbmc-88e7a15a69c32ee7d040216c585291670f3b98b4.tar.gz
talos-openbmc-88e7a15a69c32ee7d040216c585291670f3b98b4.zip
meta-hxt: add sol support
(From meta-hxt rev: 983f81795dcfb10acd7a9a138206476a0a3a1bb0) Change-Id: I745e731c32cfaf3c8e367a56b596dc2e6140a01f Signed-off-by: Yuan Yao <yao.yuan@hxt-semitech.com> Signed-off-by: Andrew Geissler <geissonator@yahoo.com>
Diffstat (limited to 'meta-hxt')
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console/obmc-console.conf2
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console_%.bbappend2
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client.bb10
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client.sh5
-rw-r--r--meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client@.service9
5 files changed, 28 insertions, 0 deletions
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console/obmc-console.conf b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console/obmc-console.conf
new file mode 100644
index 000000000..85f35c190
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console/obmc-console.conf
@@ -0,0 +1,2 @@
+local-tty = ttyS2
+local-tty-baud = 115200
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console_%.bbappend b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console_%.bbappend
new file mode 100644
index 000000000..91909f129
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/obmc-console_%.bbappend
@@ -0,0 +1,2 @@
+FILESEXTRAPATHS_prepend_stardragon4800-rep2 := "${THISDIR}/${PN}:"
+OBMC_CONSOLE_HOST_TTY = "ttyS2"
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client.bb b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client.bb
new file mode 100644
index 000000000..879f7a520
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client.bb
@@ -0,0 +1,10 @@
+FILESEXTRAPATHS_prepend_stardragon4800-rep2 := "${THISDIR}/${PN}:"
+LICENSE = "Apache-2.0"
+LIC_FILES_CHKSUM = "file://${HXTBASE}/COPYING.apache-2.0;md5=34400b68072d710fecd0a2940a0d1658"
+
+SRC_URI += "file://stardragon4800-rep2-console-client.sh"
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/stardragon4800-rep2-console-client.sh ${D}${bindir}/stardragon4800-rep2-console-client.sh
+}
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client.sh b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client.sh
new file mode 100644
index 000000000..a95c1a656
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client.sh
@@ -0,0 +1,5 @@
+#!/bin/sh -e
+#Control UART mux for obmc-console-client
+echo 0 > /sys/class/gpio/gpio325/value
+obmc-console-client
+echo 1 > /sys/class/gpio/gpio325/value
diff --git a/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client@.service b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client@.service
new file mode 100644
index 000000000..dce0eec0d
--- /dev/null
+++ b/meta-hxt/meta-stardragon4800-rep2/recipes-phosphor/console/stardragon4800-rep2-console-client/stardragon4800-rep2-console-client@.service
@@ -0,0 +1,9 @@
+[Unit]
+Description=Control UART mux for obmc-console-client
+
+[Service]
+ExecStart=/usr/bin/env stardragon4800-rep2-console-client.sh
+SyslogIdentifier=stardragon4800-rep2-console-client.sh
+
+[Install]
+WantedBy={SYSTEMD_DEFAULT_TARGET}
OpenPOWER on IntegriCloud