summaryrefslogtreecommitdiffstats
path: root/import-layers/meta-raspberrypi/recipes-bsp
diff options
context:
space:
mode:
authorBrad Bishop <bradleyb@fuzziesquirrel.com>2017-12-04 02:17:07 -0500
committerBrad Bishop <bradleyb@fuzziesquirrel.com>2017-12-14 23:28:04 +0000
commit3a5fbf530231e55aab91bc86ca1733b5fa3b6951 (patch)
treec0c8341127dc264047c9dce3481192fe632c4270 /import-layers/meta-raspberrypi/recipes-bsp
parent7f28bc5ce604549f6a1ef536e8d7eafe0d779a79 (diff)
downloadtalos-openbmc-3a5fbf530231e55aab91bc86ca1733b5fa3b6951.tar.gz
talos-openbmc-3a5fbf530231e55aab91bc86ca1733b5fa3b6951.zip
Squashed 'import-layers/meta-raspberrypi/' changes from cce6292e414..2a192261a91
Yocto 2.2.2 (Morty) Change-Id: I96e39defae033e9f458f7c38a3b67296d6b3060f git-subtree-dir: import-layers/meta-raspberrypi git-subtree-split: 2a192261a914892019f4f428d7462bb3c585ebac Signed-off-by: Brad Bishop <bradleyb@fuzziesquirrel.com>
Diffstat (limited to 'import-layers/meta-raspberrypi/recipes-bsp')
-rw-r--r--import-layers/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb6
-rw-r--r--import-layers/meta-raspberrypi/recipes-bsp/common/firmware.inc6
2 files changed, 9 insertions, 3 deletions
diff --git a/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb b/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
index f6107180d..20ec34392 100644
--- a/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
+++ b/import-layers/meta-raspberrypi/recipes-bsp/bootfiles/rpi-config_git.bb
@@ -112,6 +112,12 @@ do_deploy() {
fi
}
+do_deploy_append_raspberrypi3-64() {
+ # Device Tree support
+ echo "# Load correct Device Tree for Aarch64" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+ echo "device_tree=bcm2710-rpi-3-b.dtb" >>${DEPLOYDIR}/bcm2835-bootfiles/config.txt
+}
+
addtask deploy before do_package after do_install
do_deploy[dirs] += "${DEPLOYDIR}/bcm2835-bootfiles"
diff --git a/import-layers/meta-raspberrypi/recipes-bsp/common/firmware.inc b/import-layers/meta-raspberrypi/recipes-bsp/common/firmware.inc
index 1961b48bc..1c3a911dd 100644
--- a/import-layers/meta-raspberrypi/recipes-bsp/common/firmware.inc
+++ b/import-layers/meta-raspberrypi/recipes-bsp/common/firmware.inc
@@ -1,10 +1,10 @@
-RPIFW_DATE ?= "20161125"
+RPIFW_DATE ?= "20170405"
RPIFW_SRC_URI ?= "https://github.com/raspberrypi/firmware/archive/1.${RPIFW_DATE}.tar.gz"
RPIFW_S ?= "${WORKDIR}/firmware-1.${RPIFW_DATE}"
SRC_URI = "${RPIFW_SRC_URI}"
-SRC_URI[md5sum] = "a9281d2869e2d7673a83d41bacfa66c2"
-SRC_URI[sha256sum] = "744e050630621c70991c91e0ee8663dc2f579e743583ca762b13b00bc75859bc"
+SRC_URI[md5sum] = "ea82d14a7cd8cfae9b78e00d4e56bc71"
+SRC_URI[sha256sum] = "2f4e5bddbac1372590db203002c35cbba3fb9d6172a93c314ee27bf05ae13bff"
PV = "${RPIFW_DATE}"
OpenPOWER on IntegriCloud