summaryrefslogtreecommitdiffstats
path: root/libstdc++-v3/po/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'libstdc++-v3/po/Makefile.am')
-rw-r--r--libstdc++-v3/po/Makefile.am14
1 files changed, 8 insertions, 6 deletions
diff --git a/libstdc++-v3/po/Makefile.am b/libstdc++-v3/po/Makefile.am
index fe3a6fbed72..b7c3309df9b 100644
--- a/libstdc++-v3/po/Makefile.am
+++ b/libstdc++-v3/po/Makefile.am
@@ -23,11 +23,6 @@
PACKAGE = @PACKAGE@
-# Necessary files.
-DISTFILES = \
- Makefile.am Makefile.in POTFILES.in $(PACKAGE).pot \
- $(LOCALE_IN)
-
# Location of installation directories.
locale_installdir = $(DESTDIR)$(datadir)/locale
locale_builddir = @glibcpp_localedir@
@@ -35,9 +30,16 @@ locale_builddir = @glibcpp_localedir@
# Tell automake that foo.po makes foo.mo
SUFFIXES = .po .mo
-LOCALE_IN = @POFILES@
+LOCALE_IN = @glibcpp_POFILES@
LOCALE_OUT = @glibcpp_MOFILES@
+MSGFMT = msgfmt
+
+# Necessary files.
+DISTFILES = \
+ Makefile.am Makefile.in string_literals.cc POTFILES.in $(PACKAGE).pot \
+ $(LOCALE_IN)
+
.po.mo:
$(MSGFMT) $< -o $@
OpenPOWER on IntegriCloud