summaryrefslogtreecommitdiffstats
path: root/libvtv/configure.ac
diff options
context:
space:
mode:
authorbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2013-08-07 23:40:49 +0000
committerbkoz <bkoz@138bc75d-0d04-0410-961f-82ee72b054a4>2013-08-07 23:40:49 +0000
commit0adca0561a9541e61b48d62bce5762313e745709 (patch)
tree0fc17ee70a3ffdba97eb50442871c4f2fe15a091 /libvtv/configure.ac
parent81d635d9636fafae8379a45c761bcfb6ac3e73bf (diff)
downloadppe42-gcc-0adca0561a9541e61b48d62bce5762313e745709.tar.gz
ppe42-gcc-0adca0561a9541e61b48d62bce5762313e745709.zip
2013-08-07 Benjamin Kosnik <bkoz@rehat.com>
* Makefile.am (SUBDIRS): Protect with ENABLE_VTABLE_VERIFY. * Makefile.in: Regenerate. * acinclude.m4 (LIBVTV_CONFIGURE): Move parts to.. * configure.ac: ...here. Make configure more verbose, re-order. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@201585 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libvtv/configure.ac')
-rw-r--r--libvtv/configure.ac37
1 files changed, 30 insertions, 7 deletions
diff --git a/libvtv/configure.ac b/libvtv/configure.ac
index cc8e28098ed..47243122616 100644
--- a/libvtv/configure.ac
+++ b/libvtv/configure.ac
@@ -20,6 +20,34 @@ AC_ARG_ENABLE(version-specific-runtime-libs,
[version_specific_libs=no])
AC_MSG_RESULT($version_specific_libs)
+# Use same top-level configure hooks in libgcc/libstdc++/libvtv.
+AC_MSG_CHECKING([for --enable-vtable-verify])
+AC_ARG_ENABLE(vtable-verify,
+[ --enable-vtable-verify Enable vtable verification feature ],
+[case "$enableval" in
+ yes) enable_vtable_verify=yes ;;
+ no) enable_vtable_verify=no ;;
+ *) enable_vtable_verify=no;;
+ esac],
+[enable_vtable_verify=no])
+AC_MSG_RESULT($enable_vtable_verify)
+
+# See if supported.
+unset VTV_SUPPORTED
+AC_MSG_CHECKING([for host support for vtable verification])
+. ${srcdir}/configure.tgt
+AC_MSG_RESULT($VTV_SUPPORTED)
+
+# Decide if it's usable.
+use_vtable_verify=no
+if test "x$VTV_SUPPORTED" = "xyes"; then
+ if test "x$enable_vtable_verify" = "xyes"; then
+ use_vtable_verify=yes
+ AC_MSG_NOTICE(using vtable verification)
+ fi
+fi
+AM_CONDITIONAL(ENABLE_VTABLE_VERIFY, test $use_vtable_verify = yes)
+
# Do not delete or change the following two lines. For why, see
# http://gcc.gnu.org/ml/libstdc++/2003-07/msg00451.html
AC_CANONICAL_SYSTEM
@@ -31,6 +59,8 @@ AM_INIT_AUTOMAKE(foreign no-dist)
AM_ENABLE_MULTILIB(, ..)
AM_MAINTAINER_MODE
+LIBVTV_CONFIGURE
+
# Calculate toolexeclibdir
# Also toolexecdir, though it's only used in toolexeclibdir
case ${version_specific_libs} in
@@ -102,13 +132,6 @@ else
multilib_arg=
fi
-LIBVTV_CONFIGURE
-
-# Get target configury.
-unset VTV_SUPPORTED
-. ${srcdir}/configure.tgt
-AM_CONDITIONAL(VTV_SUPPORTED, [test "x$VTV_SUPPORTED" = "xyes"])
-
AC_CONFIG_FILES([Makefile])
if test "x$VTV_SUPPORTED" = "xyes"; then
OpenPOWER on IntegriCloud