summaryrefslogtreecommitdiffstats
path: root/libstdc++-v3/libsupc++/Makefile.am
diff options
context:
space:
mode:
authormmitchel <mmitchel@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-02 20:28:22 +0000
committermmitchel <mmitchel@138bc75d-0d04-0410-961f-82ee72b054a4>2004-08-02 20:28:22 +0000
commitece3a793c48557f7b525fff8e127aa301a8c3422 (patch)
tree83cf70f3bb386c3241e58e367ac7decf0c8985a8 /libstdc++-v3/libsupc++/Makefile.am
parent48bdfbc821a401b9c18be7a664087cc28006f845 (diff)
downloadppe42-gcc-ece3a793c48557f7b525fff8e127aa301a8c3422.tar.gz
ppe42-gcc-ece3a793c48557f7b525fff8e127aa301a8c3422.zip
* Makefile.am (hosted_source): Add libmath and testsuite.
(SUBDIRS): Remove them. * acinclude.m4: (GLIBCXX_ENABLED_HOSTED): Default to freestanding on arm*-*-symbianelf*. * crossconfig.m4: Add arm*-*-symbianelf* support. * include/c_std/std/std_cstdlib.h (stdlib.h): Do not include it when freestanding. Do not bring names into std:: namespace with "using" when freestanding. Declare required functions and macros when freestanding. * libsupc++/Makefile.am (c_sources): Do not include cp-demangle.c when freestanding. * libsupc++/del_op.cc: Declare "free" only when freestanding. * libsupc++/eh_alloc.cc (cstring): Include it only when hosted. (malloc): Declare when freestanding. (free): Likewise. (memset): Likewise. (__cxa_allocate_exception): Call malloc, not std::malloc. Likewise for memset. (__cxa_free_exception): Likewise for free. * libsupc++/new_op.cc: Declare "malloc" when freestanding. * libsupc++/pure.cc (writestr): Define to nothing when freestanding. * libsupc++/vterminate.cc: Do not define anything when freestanding. * Makefile.in: Regenerated. * aclocal.m4: Likewise. * configure: Likewise. * include/Makefile.in: Likewise. * libmath/Makefile.in: Likewise. * libsupc++/Makefile.in: Likewise. * po/Makefile.in: Likewise. * src/Makefile.in: Likewise. * testsuite/Makefile.in: Likewise. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@85452 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/libsupc++/Makefile.am')
-rw-r--r--libstdc++-v3/libsupc++/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libstdc++-v3/libsupc++/Makefile.am b/libstdc++-v3/libsupc++/Makefile.am
index 5550686728a..a55ef6626a2 100644
--- a/libstdc++-v3/libsupc++/Makefile.am
+++ b/libstdc++-v3/libsupc++/Makefile.am
@@ -34,8 +34,10 @@ noinst_LTLIBRARIES = libsupc++convenience.la
headers = \
exception new typeinfo cxxabi.h exception_defines.h
-c_sources = \
+if GLIBCXX_HOSTED
+ c_sources = \
cp-demangle.c
+endif
sources = \
del_op.cc \
OpenPOWER on IntegriCloud