summaryrefslogtreecommitdiffstats
path: root/libstdc++-v3/include/Makefile.am
diff options
context:
space:
mode:
authorjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-01 04:02:45 +0000
committerjason <jason@138bc75d-0d04-0410-961f-82ee72b054a4>2011-11-01 04:02:45 +0000
commitfbb4cdfc5596ff0c5bd1e699a9b103fb4d6d56dc (patch)
tree0ededd9412f3ae08e4c8e3ac8f0e81721497a143 /libstdc++-v3/include/Makefile.am
parent4bbee633b65b4cc789ac6cfa0f8e4eda07d952d5 (diff)
downloadppe42-gcc-fbb4cdfc5596ff0c5bd1e699a9b103fb4d6d56dc.tar.gz
ppe42-gcc-fbb4cdfc5596ff0c5bd1e699a9b103fb4d6d56dc.zip
* include/Makefile.am (install-freestanding-headers): Install
c++0x_warning.h. * libsupc++/initializer_list: Include it. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@180727 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libstdc++-v3/include/Makefile.am')
-rw-r--r--libstdc++-v3/include/Makefile.am4
1 files changed, 3 insertions, 1 deletions
diff --git a/libstdc++-v3/include/Makefile.am b/libstdc++-v3/include/Makefile.am
index 02deefc7222..74acbf0c88a 100644
--- a/libstdc++-v3/include/Makefile.am
+++ b/libstdc++-v3/include/Makefile.am
@@ -1201,8 +1201,10 @@ endif
# are installed by libsupc++, so only the first four and the sub-includes
# are copied here.
install-freestanding-headers:
- $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}
+ $(mkinstalldirs) $(DESTDIR)${gxx_include_dir}/bits
$(mkinstalldirs) $(DESTDIR)${host_installdir}
+ $(INSTALL_DATA) ${glibcxx_srcdir}/include/bits/c++0x_warning.h \
+ $(DESTDIR)${gxx_include_dir}/bits
for file in ${host_srcdir}/os_defines.h ${host_builddir}/c++config.h \
${glibcxx_srcdir}/$(ABI_TWEAKS_SRCDIR)/cxxabi_tweaks.h \
${glibcxx_srcdir}/$(CPU_DEFINES_SRCDIR)/cpu_defines.h; do \
OpenPOWER on IntegriCloud