summaryrefslogtreecommitdiffstats
path: root/libquadmath/Makefile.am
diff options
context:
space:
mode:
authorburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-08 08:06:49 +0000
committerburnus <burnus@138bc75d-0d04-0410-961f-82ee72b054a4>2010-12-08 08:06:49 +0000
commitd658011316dbae0762a14f294c9395a3a33ac103 (patch)
tree2b1ed8c40ac9bc96e92cf0633b01f6ea4c4a5e23 /libquadmath/Makefile.am
parent7d17fab3d03af64501d703bcb59f8870220c4ed1 (diff)
downloadppe42-gcc-d658011316dbae0762a14f294c9395a3a33ac103.tar.gz
ppe42-gcc-d658011316dbae0762a14f294c9395a3a33ac103.zip
2010-12-08 Tobias Burnus <burnus@net-b.de>
PR fortran/46543 * configure.ac: Add texinfo checks. * Makefile.am: Handle .texi documentation. * libquadmath.texi: New. * configure: Regenerated. * Makefile.in: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@167583 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libquadmath/Makefile.am')
-rw-r--r--libquadmath/Makefile.am42
1 files changed, 42 insertions, 0 deletions
diff --git a/libquadmath/Makefile.am b/libquadmath/Makefile.am
index c1f0b638d55..e9071237755 100644
--- a/libquadmath/Makefile.am
+++ b/libquadmath/Makefile.am
@@ -105,4 +105,46 @@ AM_MAKEFLAGS = \
MAKEOVERRIDES=
+# AM_CONDITIONAL on configure option --generated-files-in-srcdir
+if GENINSRC
+STAMP_GENINSRC = stamp-geninsrc
+else
+STAMP_GENINSRC =
+endif
+
+# AM_CONDITIONAL on configure check ACX_CHECK_PROG_VER([MAKEINFO])
+if BUILD_INFO
+STAMP_BUILD_INFO = stamp-build-info
+else
+STAMP_BUILD_INFO =
endif
+
+
+all-local: $(STAMP_GENINSRC)
+
+stamp-geninsrc: libquadmath.info
+ cp -p $(top_builddir)/libquadmath.info $(srcdir)/libquadmath.info
+ @touch $@
+
+libquadmath.info: $(STAMP_BUILD_INFO)
+
+stamp-build-info: libquadmath.texi
+ $(MAKEINFO) $(AM_MAKEINFOFLAGS) $(MAKEINFOFLAGS) -I $(srcdir) -o libquadmath.info $(srcdir)/libquadmath.texi
+ @touch $@
+
+CLEANFILES = $(STAMP_GENINSRC) $(STAMP_BUILD_INFO) libquadmath.info
+MAINTAINERCLEANFILES = $(srcdir)/libquadmath.info
+
+endif
+
+
+# Automake Documentation:
+# If your package has Texinfo files in many directories, you can use the
+# variable TEXINFO_TEX to tell Automake where to find the canonical
+# `texinfo.tex' for your package. The value of this variable should be
+# the relative path from the current `Makefile.am' to `texinfo.tex'.
+TEXINFO_TEX = ../gcc/doc/include/texinfo.tex
+
+# Defines info, dvi, pdf and html targets
+MAKEINFOFLAGS = -I $(srcdir)/../gcc/doc/include
+info_TEXINFOS = libquadmath.texi
OpenPOWER on IntegriCloud