summaryrefslogtreecommitdiffstats
path: root/libjava/configure.ac
diff options
context:
space:
mode:
authordaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2008-09-05 17:09:02 +0000
committerdaney <daney@138bc75d-0d04-0410-961f-82ee72b054a4>2008-09-05 17:09:02 +0000
commitd279db8d38c6150ebc07368d1588c032b6a696a7 (patch)
tree5d217d4a6170f98ed2c4e56aa9f9040d46d5fdeb /libjava/configure.ac
parentcdc6ffd9cee23cf7bbb0f495e1135d31cf055c0f (diff)
downloadppe42-gcc-d279db8d38c6150ebc07368d1588c032b6a696a7.tar.gz
ppe42-gcc-d279db8d38c6150ebc07368d1588c032b6a696a7.zip
2008-09-05 David Daney <ddaney@avtrex.com>
* doc/install.texi (--enable-reduced-reflection): Document new option. 2008-09-05 David Daney <ddaney@avtrex.com> * configure.ac (reduced-reflection): New AC_ARG_ENABLE. (build_libgcj_reduced_reflection): New variable. (BUILD_LIBGCJ_REDUCED_REFLECTION): New AM_CONDITIONAL. * Makefile.am (LIBGCJ_REDUCED_REFLECTION_FLAGS): New variable. (%.lo: %.list): Add LIBGCJ_REDUCED_REFLECTION_FLAGS to compile command. (java/util/concurrent.lo, java/util/concurrent/atomic.lo, java/util/concurrent/locks.lo): Override LIBGCJ_REDUCED_REFLECTION_FLAGS. * Makefile.in, include/Makefile.in, testsuite/Makefile.in, gcj/Makefile.in, configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@140038 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/configure.ac')
-rw-r--r--libjava/configure.ac9
1 files changed, 9 insertions, 0 deletions
diff --git a/libjava/configure.ac b/libjava/configure.ac
index 6b7949f689f..fc2083f81dc 100644
--- a/libjava/configure.ac
+++ b/libjava/configure.ac
@@ -526,6 +526,15 @@ AC_ARG_ENABLE(libgcj-bc,
fi])
AM_CONDITIONAL(SUPPRESS_LIBGCJ_BC, test "$suppress_libgcj_bc" = "yes")
+build_libgcj_reduced_reflection=no
+AC_ARG_ENABLE(reduced-reflection,
+ AS_HELP_STRING([--enable-reduced-reflection],
+ [enable or disable(default) -freduced-reflection when building portions of libgcj]),
+ [if test "$enable_reduced_reflection" = "yes"; then
+ build_libgcj_reduced_reflection=yes
+ fi])
+AM_CONDITIONAL(BUILD_LIBGCJ_REDUCED_REFLECTION, test "$build_libgcj_reduced_reflection" = "yes")
+
# What is the native OS API for MinGW?
AC_ARG_WITH(win32-nlsapi,
AS_HELP_STRING([--with-win32-nlsapi=ansi or unicows or unicode],
OpenPOWER on IntegriCloud