summaryrefslogtreecommitdiffstats
path: root/libjava/classpath/configure.ac
diff options
context:
space:
mode:
authordoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2012-12-19 17:03:15 +0000
committerdoko <doko@138bc75d-0d04-0410-961f-82ee72b054a4>2012-12-19 17:03:15 +0000
commit6fec1adc6432eeafcdea2ab165989e170cb6e64e (patch)
tree9b478aacc6b13f1beadacec2ade096dcb732af53 /libjava/classpath/configure.ac
parentabae7d71da9352babb77917224e837ffdfa118be (diff)
downloadppe42-gcc-6fec1adc6432eeafcdea2ab165989e170cb6e64e.tar.gz
ppe42-gcc-6fec1adc6432eeafcdea2ab165989e170cb6e64e.zip
2012-12-19 Matthias Klose <doko@ubuntu.com>
Import GNU Classpath (20121202). * Regenerate class and header files. * Regenerate auto* files. * sources.am, gcj/javaprims.h: Regenerate. * gnu/java/nio/FileLockImpl.java (close): New override. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@194618 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/classpath/configure.ac')
-rw-r--r--libjava/classpath/configure.ac14
1 files changed, 9 insertions, 5 deletions
diff --git a/libjava/classpath/configure.ac b/libjava/classpath/configure.ac
index 60121a56356..910c8f02e9a 100644
--- a/libjava/classpath/configure.ac
+++ b/libjava/classpath/configure.ac
@@ -6,7 +6,7 @@ dnl -----------------------------------------------------------
dnl define([AC_CACHE_LOAD], )dnl
dnl define([AC_CACHE_SAVE], )dnl
-AC_INIT([GNU Classpath],[0.99],[classpath@gnu.org],[classpath])
+AC_INIT([GNU Classpath],[0.99.1-pre],[classpath@gnu.org],[classpath])
AC_CONFIG_SRCDIR(java/lang/System.java)
AC_CONFIG_MACRO_DIR([m4])
@@ -75,7 +75,7 @@ CLASSPATH_CONVENIENCE="-no-undefined"
AC_SUBST(CLASSPATH_CONVENIENCE)
AC_PREREQ(2.64)
-AM_INIT_AUTOMAKE([1.9.0 gnu std-options tar-ustar -Wno-portability])
+AM_INIT_AUTOMAKE([1.9.0 no-dist gnu std-options tar-ustar -Wno-portability])
AC_CONFIG_HEADERS([include/config.h])
AC_PREFIX_DEFAULT(/usr/local/classpath)
@@ -183,9 +183,9 @@ AC_ARG_ENABLE([Werror],
[case "${enableval}" in
yes) ENABLE_WERROR=yes ;;
no) ENABLE_WERROR=no ;;
- *) ENABLE_WERROR=default ;;
+ *) ENABLE_WERROR=no ;;
esac],
- [ENABLE_WERROR=default])
+ [ENABLE_WERROR=no])
dnl -----------------------------------------------------------
dnl Default AWT toolkit
@@ -703,7 +703,11 @@ if test "x${COMPILE_JNI}" = xyes; then
QT_CFLAGS="$QT_CFLAGS -I$EXTRA_QT_INCLUDE_DIR",
AC_MSG_WARN([QWidget not found])))
AC_CHECK_PROG(MOC, [moc], [moc])
- AC_CHECK_PROG(MOC, [moc-qt4], [moc-qt4])
+ AC_CHECK_PROG(MOC4, [moc-qt4], [moc-qt4])
+ if test x"$MOC4" != x ; then
+ AC_MSG_NOTICE([Using $MOC4 as moc])
+ MOC=$MOC4;
+ fi
fi
if test "x$HAVE_QT4" = "xno"; then
AC_MSG_NOTICE([Looking for QT_CFLAGS and QT_LIBS without pkg-config])
OpenPOWER on IntegriCloud