summaryrefslogtreecommitdiffstats
path: root/libjava/classpath/configure.ac
diff options
context:
space:
mode:
authoraph <aph@138bc75d-0d04-0410-961f-82ee72b054a4>2008-06-24 13:30:55 +0000
committeraph <aph@138bc75d-0d04-0410-961f-82ee72b054a4>2008-06-24 13:30:55 +0000
commit000ba44200cacefdafb986824b8047e1308f0062 (patch)
tree9446535e75e8d93766d6899dec7200fb2debc135 /libjava/classpath/configure.ac
parent2ac441f789cfb646ead90083ad6a933f72e24b42 (diff)
downloadppe42-gcc-000ba44200cacefdafb986824b8047e1308f0062.tar.gz
ppe42-gcc-000ba44200cacefdafb986824b8047e1308f0062.zip
2008-06-11 Andrew Haley <aph@redhat.com>
* native/jawt/Makefile.am, native/fdlibm/Makefile.am, native/jni/java-util/Makefile.am, native/jni/gstreamer-peer/Makefile.am, native/jni/native-lib/Makefile.am, native/jni/gconf-peer/Makefile.am, native/jni/gtk-peer/Makefile.am, native/jni/xmlj/Makefile.am, native/jni/midi-alsa/Makefile.am, native/jni/java-nio/Makefile.am, native/jni/midi-dssi/Makefile.am, native/jni/classpath/Makefile.am, native/jni/java-io/Makefile.am, native/jni/java-lang/Makefile.am, native/jni/java-net/Makefile.am (AM_CFLAGS): Add @EXTRA_CFLAGS@. * configure.ac (EXTRA_CFLAGS): New macro. * lib/Makefile.am (resources): Add .svn. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@137072 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/classpath/configure.ac')
-rw-r--r--libjava/classpath/configure.ac6
1 files changed, 6 insertions, 0 deletions
diff --git a/libjava/classpath/configure.ac b/libjava/classpath/configure.ac
index d1f34ca28b3..96db95d9749 100644
--- a/libjava/classpath/configure.ac
+++ b/libjava/classpath/configure.ac
@@ -503,6 +503,12 @@ if test "x${COMPILE_JNI}" = xyes; then
WARNING_CFLAGS='-W -Wall -Wmissing-declarations -Wwrite-strings -Wmissing-prototypes -Wno-long-long'
AC_SUBST(WARNING_CFLAGS)
+ dnl CFLAGS that are used for all native code. We want to compile
+ dnl everything with unwinder data so that backtrace() will always
+ dnl work.
+ EXTRA_CFLAGS='-fexceptions -fasynchronous-unwind-tables'
+ AC_SUBST(EXTRA_CFLAGS)
+
dnl Strict warning flags which not every module uses.
dnl Should probably be configurable.
STRICT_WARNING_CFLAGS='-Wstrict-prototypes -pedantic'
OpenPOWER on IntegriCloud