summaryrefslogtreecommitdiffstats
path: root/libjava/Makefile.am
diff options
context:
space:
mode:
authortromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-03 00:15:46 +0000
committertromey <tromey@138bc75d-0d04-0410-961f-82ee72b054a4>2005-02-03 00:15:46 +0000
commitd71697530156acd7f0a5427c200ac12e1f47ef32 (patch)
tree35d4e1e38e43a58316ee54cad960f3aadee5a5a4 /libjava/Makefile.am
parent3a88b1db849af358d1f46c079460ec807fed9c9e (diff)
downloadppe42-gcc-d71697530156acd7f0a5427c200ac12e1f47ef32.tar.gz
ppe42-gcc-d71697530156acd7f0a5427c200ac12e1f47ef32.zip
* Makefile.in: Rebuilt.
* Makefile.am (classes.stamp): New target, broken out from libgcj.jar target. ($(all_java_class_files)): Depend on it. (libgcj-@gcc_version@.jar): Likewise. (all-recursive): Likewise. (CLEANFILES): Include classes.stamp. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@94636 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libjava/Makefile.am')
-rw-r--r--libjava/Makefile.am48
1 files changed, 14 insertions, 34 deletions
diff --git a/libjava/Makefile.am b/libjava/Makefile.am
index a3ad469f3e1..3daf09bd7da 100644
--- a/libjava/Makefile.am
+++ b/libjava/Makefile.am
@@ -504,39 +504,16 @@ if ONESTEP
# Compile all classfiles in one go.
-libgcj-@gcc_version@.jar: $(all_java_source_files)
- -@rm -f libgcj-@gcc_version@.jar
+classes.stamp: $(all_java_source_files)
@echo Compiling Java sourcefiles...
@: $(call write_entries_to_file,$?,libgcj.sourcelist)
$(JAVAC) $(JCFLAGS) -classpath '' -bootclasspath $(BOOTCLASSPATH) -d $(here) @libgcj.sourcelist
-## Note that we explicitly want to include directory information.
- (find java gnu javax org -type d -o -type f -name '*.class'; \
-## Ugly code to avoid "echo -C". Must separate each entry by a newline
-## Gross but easy.
- for file in $(all_property_files); do \
- echo "x-C" | sed -e 's/^.//'; \
- echo $(srcdir); \
- echo $$file; \
- done) | \
- sed -e '/\/xlib/d' -e '/\/\.libs/d' -e '/\/\.deps/d' | \
- $(ZIP) -cfM0E@ $@
-## Now include the classes from external/.
- for dir in sax w3c_dom; do \
- (cd external/$$dir; \
- find org -type f -name '*.class' -print | while read file; do \
- echo "x-C" | sed -e 's/^.//'; \
- echo external/$$dir; \
- echo $$file; \
- done) | \
- $(ZIP) -ufM0E@ $@; \
- done
-# This next rule seems backward, but reflects the fact
-# that 1) all classfiles are compiled in one go when the
-# libgcj jarfile is built and 2) anything which depends
-# on a particular .class file must wait until the jarfile
-# is built.
-$(all_java_class_files): libgcj-@gcc_version@.jar
+# This next rule seems backward, but reflects the fact that 1) all
+# classfiles are compiled in one go when classes.stamp is built and 2)
+# anything which depends on a particular .class file must wait until
+# this file is built.
+$(all_java_class_files): classes.stamp
else # !ONESTEP
@@ -545,7 +522,12 @@ else # !ONESTEP
.java.class:
$(JAVAC) $(JCFLAGS) -classpath '' -bootclasspath $(BOOTCLASSPATH) -d $(here) $<
-libgcj-@gcc_version@.jar: $(all_java_class_files) $(all_property_files)
+classes.stamp: $(all_java_class_files) $(all_property_files)
+ echo > classes.stamp
+
+endif
+
+libgcj-@gcc_version@.jar: classes.stamp
-@rm -f libgcj-@gcc_version@.jar
## Note that we explicitly want to include directory information.
(find java gnu javax org -type d -o -type f -name '*.class'; \
@@ -569,9 +551,7 @@ libgcj-@gcc_version@.jar: $(all_java_class_files) $(all_property_files)
$(ZIP) -ufM0E@ $@; \
done
-endif
-
-CLEANFILES = libgcj-@gcc_version@.jar
+CLEANFILES = libgcj-@gcc_version@.jar classes.stamp
mostlyclean-local:
## Use libtool rm to remove each libtool object
@@ -3761,7 +3741,7 @@ texinfo: TexinfoDoclet.class
## the C++ code whenever any .java file is touched.
## Also force all the class files to build first. This makes them build in
## the right order to improve performance.
-all-recursive: libgcj-@gcc_version@.jar $(nat_headers) $(xlib_nat_headers)
+all-recursive: classes.stamp $(nat_headers) $(xlib_nat_headers)
## ################################################################
OpenPOWER on IntegriCloud