summaryrefslogtreecommitdiffstats
path: root/libiberty/configure.in
diff options
context:
space:
mode:
authorzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2003-01-24 20:02:11 +0000
committerzack <zack@138bc75d-0d04-0410-961f-82ee72b054a4>2003-01-24 20:02:11 +0000
commit8cb0536d25508acaffb368dc075c5038eaa4e068 (patch)
treea5a1f317d0d5eb9f7466940f45f70923df577e59 /libiberty/configure.in
parent82733f8decd8b228c8152ae27fd102701250c456 (diff)
downloadppe42-gcc-8cb0536d25508acaffb368dc075c5038eaa4e068.tar.gz
ppe42-gcc-8cb0536d25508acaffb368dc075c5038eaa4e068.zip
* Makefile.in (CFILES): Add pex-*.c.
(REQUIRED_OFILES): Change pexecute.o to @pexecute@ (CONFIGURED_OFILES): Add pex-*.o. (TEXIFILES): Add pexecute.txh. (pexecute.o): Delete rule. (pex-cygwin.o, pex-djgpp.o, pex-mpw.o, pex-msdos.o, pex-os2.o, pex-unix.o, pex-win32.o): New rules. * configure.in: Change AC_INIT argument to xmalloc.c. Compute appropriate pexecute implementation and substitute it as @pexecute@. * pexecute.c: Split up into... * pex-cygwin.c, pex-djgpp.c, pex-mpw.c, pex-msdos.c, pex-os2.c, pex-unix.c, pex-win32.c, pex-common.h, pexecute.txh: ... these new files. * functions.texi: Regenerate. * configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@61728 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libiberty/configure.in')
-rw-r--r--libiberty/configure.in13
1 files changed, 12 insertions, 1 deletions
diff --git a/libiberty/configure.in b/libiberty/configure.in
index a8dc66fa83c..5b58ddb8a1c 100644
--- a/libiberty/configure.in
+++ b/libiberty/configure.in
@@ -1,7 +1,7 @@
dnl Process this file with autoconf to produce a configure script
AC_PREREQ(2.13)
-AC_INIT(pexecute.c)
+AC_INIT(xmalloc.c)
# This works around the fact that libtool configuration may change LD
# for this particular configuration, but some shells, instead of
@@ -425,6 +425,17 @@ if test -z "${setobjs}"; then
AC_CHECK_FUNCS($checkfuncs)
fi
+# Figure out which version of pexecute to use.
+case "${host}" in
+ *-*-cygwin*) pexecute=pex-cygwin.o ;;
+ *-*-mingw* | *-*-winnt*) pexecute=pex-win32.o ;;
+ *-*-msdosdjgpp*) pexecute=pex-djgpp.o ;;
+ *-*-msdos*) pexecute=pex-msdos.o ;;
+ *-*-os2-emx*) pexecute=pex-os2.o ;;
+ *) pexecute=pex-unix.o ;;
+esac
+AC_SUBST(pexecute)
+
libiberty_AC_FUNC_STRNCMP
# Install a library built with a cross compiler in $(tooldir) rather
OpenPOWER on IntegriCloud