summaryrefslogtreecommitdiffstats
path: root/libffi/configure.ac
diff options
context:
space:
mode:
authorschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2012-12-29 16:25:27 +0000
committerschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2012-12-29 16:25:27 +0000
commit8cd092c9edd1e155a21a2547c97b80db9e0a1c26 (patch)
tree38ca0d0cd63dbfc4af88ce1425e8a8c0a0d9879a /libffi/configure.ac
parentfb7a3b7abcfa020cd36d167634d48f4aa9ec9f72 (diff)
downloadppe42-gcc-8cd092c9edd1e155a21a2547c97b80db9e0a1c26.tar.gz
ppe42-gcc-8cd092c9edd1e155a21a2547c97b80db9e0a1c26.zip
* Makefile.am (ACLOCAL_AMFLAGS, TEXINFO_TEX, MAKEINFOFLAGS)
(STAMP_GENINSRC, STAMP_BUILD_INFO, CLEANFILES) (MAINTAINERCLEANFILES): Define. (all-local, stamp-geninsrc, stamp-build-info): New targets. (doc/libffi.info): Depend on $(STAMP_BUILD_INFO) * configure.ac: Check for modern makeinfo. Add support for --enable-generated-files-in-srcdir. * libffi/mdate-sh: New file. * testsuite/lib/libffi.exp (load_gcc_lib): Load from gcc testsuite lib dir. (libffi-init): Properly set library paths for multilibs and add path to libstdc++. * configure: Regenerate. * aclocal.m4: Regenerate. * Makefile.in: Regenerate. * doc/stamp-vti: Regenerate. * doc/version.texi: Regenerate. * fficonfig.h.in: Regenerate. * include/Makefile.in: Regenerate. * man/Makefile.in: Regenerate. * testsuite/Makefile.in: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@194752 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'libffi/configure.ac')
-rw-r--r--libffi/configure.ac25
1 files changed, 25 insertions, 0 deletions
diff --git a/libffi/configure.ac b/libffi/configure.ac
index d7ab0666484..22fc5690df0 100644
--- a/libffi/configure.ac
+++ b/libffi/configure.ac
@@ -14,6 +14,31 @@ target_alias=${target_alias-$host_alias}
AM_INIT_AUTOMAKE
+# See if makeinfo has been installed and is modern enough
+# that we can use it.
+ACX_CHECK_PROG_VER([MAKEINFO], [makeinfo], [--version],
+ [GNU texinfo.* \([0-9][0-9.]*\)],
+ [4.[4-9]*|4.[1-9][0-9]*|[5-9]*|[1-9][0-9]*])
+AM_CONDITIONAL(BUILD_INFO, test $gcc_cv_prog_makeinfo_modern = "yes")
+
+# We would like our source tree to be readonly. However when releases or
+# pre-releases are generated, the flex/bison generated files as well as the
+# various formats of manuals need to be included along with the rest of the
+# sources. Therefore we have --enable-generated-files-in-srcdir to do
+# just that.
+AC_MSG_CHECKING(generated-files-in-srcdir)
+AC_ARG_ENABLE(generated-files-in-srcdir,
+AS_HELP_STRING([--enable-generated-files-in-srcdir],
+ [put copies of generated files in source dir intended for creating source tarballs for users without texinfo bison or flex]),
+[case "$enableval" in
+ yes) enable_generated_files_in_srcdir=yes ;;
+ no) enable_generated_files_in_srcdir=no ;;
+ *) AC_MSG_ERROR([Unknown argument to enable/disable version-specific libs]);;
+ esac],
+[enable_generated_files_in_srcdir=no])
+AC_MSG_RESULT($enable_generated_files_in_srcdir)
+AM_CONDITIONAL(GENINSRC, test "$enable_generated_files_in_srcdir" = yes)
+
# The same as in boehm-gc and libstdc++. Have to borrow it from there.
# We must force CC to /not/ be precious variables; otherwise
# the wrong, non-multilib-adjusted value will be used in multilibs.
OpenPOWER on IntegriCloud