summaryrefslogtreecommitdiffstats
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-08 07:27:38 +0000
committerghazi <ghazi@138bc75d-0d04-0410-961f-82ee72b054a4>1999-04-08 07:27:38 +0000
commitde5102fe5e277309cd0dbd37eee03f5baa93204a (patch)
tree2d6ce2dd20cea01177b812cce1a4ad5f24e5c338 /gcc/configure.in
parent5aee76dbc223c03030a12be983e4b9d209e0ee72 (diff)
downloadppe42-gcc-de5102fe5e277309cd0dbd37eee03f5baa93204a.tar.gz
ppe42-gcc-de5102fe5e277309cd0dbd37eee03f5baa93204a.zip
* configure.in (host_xm_file, build_xm_file): Include hwint.h.
Use case statements instead of "if test -a ... -a ... -a ..." * machmode.h: Don't define HOST_WIDE_INT, etc. Wrap use of HOST_WIDE_INT in #ifdef. * mips.h: Include hwint.h instead of providing definitions for HOST_WIDE_INT, etc. Wrap uses of HOST_WIDE_INT in #ifdef. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@26291 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in36
1 files changed, 18 insertions, 18 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 2b1dd421a36..75852375563 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -3551,14 +3551,14 @@ fi
# auto-host.h is the file containing items generated by autoconf and is
# the first file included by config.h.
null_defines=
-host_xm_file="auto-host.h gansidecl.h ${host_xm_file}"
+host_xm_file="auto-host.h gansidecl.h ${host_xm_file} hwint.h"
# If host=build, it is correct to have hconfig include auto-host.h
# as well. If host!=build, we are in error and need to do more
# work to find out the build config parameters.
if test x$host = x$build
then
- build_xm_file="auto-host.h gansidecl.h ${build_xm_file}"
+ build_xm_file="auto-host.h gansidecl.h ${build_xm_file} hwint.h"
else
# We create a subdir, then run autoconf in the subdir.
# To prevent recursion we set host and build for the new
@@ -3580,7 +3580,7 @@ else
mv auto-host.h ../auto-build.h
cd ..
rm -rf $tempdir
- build_xm_file="auto-build.h gansidecl.h ${build_xm_file}"
+ build_xm_file="auto-build.h gansidecl.h ${build_xm_file} hwint.h"
fi
xm_file="gansidecl.h ${xm_file}"
@@ -3726,29 +3726,29 @@ out_object_file=`basename $out_file .c`.o
tm_file_list=
for f in $tm_file; do
- if test $f != "gansidecl.h" ; then
- tm_file_list="${tm_file_list} \$(srcdir)/config/$f"
- else
- tm_file_list="${tm_file_list} $f"
- fi
+ case $f in
+ gansidecl.h )
+ tm_file_list="${tm_file_list} $f" ;;
+ *) tm_file_list="${tm_file_list} \$(srcdir)/config/$f" ;;
+ esac
done
host_xm_file_list=
for f in $host_xm_file; do
- if test $f != "auto-host.h" -a $f != "gansidecl.h" ; then
- host_xm_file_list="${host_xm_file_list} \$(srcdir)/config/$f"
- else
- host_xm_file_list="${host_xm_file_list} $f"
- fi
+ case $f in
+ auto-host.h | gansidecl.h | hwint.h )
+ host_xm_file_list="${host_xm_file_list} $f" ;;
+ *) host_xm_file_list="${host_xm_file_list} \$(srcdir)/config/$f" ;;
+ esac
done
build_xm_file_list=
for f in $build_xm_file; do
- if test $f != "auto-build.h" -a $f != "auto-host.h" -a $f != "gansidecl.h" ; then
- build_xm_file_list="${build_xm_file_list} \$(srcdir)/config/$f"
- else
- build_xm_file_list="${build_xm_file_list} $f"
- fi
+ case $f in
+ auto-build.h | auto-host.h | gansidecl.h | hwint.h )
+ build_xm_file_list="${build_xm_file_list} $f" ;;
+ *) build_xm_file_list="${build_xm_file_list} \$(srcdir)/config/$f" ;;
+ esac
done
# Define macro CROSS_COMPILE in compilation
OpenPOWER on IntegriCloud