summaryrefslogtreecommitdiffstats
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2001-11-15 12:11:52 +0000
committerschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2001-11-15 12:11:52 +0000
commit74e387fc329ac9d32167f52bf5ab5e3eb9865bee (patch)
tree3793dcb7440df2f93e667a76d8275b29f75d120e /gcc/configure.in
parent022d474c505cff055194c93b9d9a662e62c79b2c (diff)
downloadppe42-gcc-74e387fc329ac9d32167f52bf5ab5e3eb9865bee.tar.gz
ppe42-gcc-74e387fc329ac9d32167f52bf5ab5e3eb9865bee.zip
* configure.in: Check for target objdump and use that in eh_frame
optimization test. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@47051 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in15
1 files changed, 13 insertions, 2 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 56edfd7fe6a..633050f4f23 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -1133,9 +1133,10 @@ if test -f ../gas/Makefile; then
rm -f as; $symbolic_link ../gas/as-new$host_exeext as$host_exeext 2>/dev/null
fi
-# If we have nm in the build tree, make a link to it.
+# If we have nm and objdump in the build tree, make a link to them.
if test -f ../binutils/Makefile; then
rm -f nm; $symbolic_link ../binutils/nm-new$host_exeext nm$host_exeext 2>/dev/null
+ rm -f objdump; $symbolic_link ../binutils/objdump$host_exeext objdump$host_exeext 2>/dev/null
fi
# If we have ld in the build tree, make a link to it.
@@ -1242,6 +1243,16 @@ elif test x$host = x$target; then
fi
AC_MSG_RESULT($gcc_cv_nm)
+# Figure out what objdump we will be using.
+AC_MSG_CHECKING(what objdump to use)
+if test -x objdump$host_exeext; then
+ gcc_cv_objdump=./objdump$host_exeext
+elif test x$host = x$target; then
+ # Native build.
+ gcc_cv_objdump=objdump$host_exeext
+fi
+AC_MSG_RESULT($gcc_cv_objdump)
+
# Figure out what assembler alignment features are present.
AC_MSG_CHECKING(assembler alignment features)
gcc_cv_as_alignment_features=none
@@ -1460,7 +1471,7 @@ EOF
# If the assembler didn't choke, and we can objdump,
# and we got the correct data, then succeed.
if $gcc_cv_as -o conftest.o conftest.s > /dev/null 2>&1 \
- && objdump -s -j .eh_frame conftest.o 2>/dev/null \
+ && $gcc_cv_objdump -s -j .eh_frame conftest.o 2>/dev/null \
| tail -3 > conftest.got \
&& { cmp conftest.lit conftest.got > /dev/null 2>&1 \
|| cmp conftest.big conftest.got > /dev/null 2>&1; }
OpenPOWER on IntegriCloud