summaryrefslogtreecommitdiffstats
path: root/gcc/configure.in
diff options
context:
space:
mode:
authorrobertl <robertl@138bc75d-0d04-0410-961f-82ee72b054a4>1999-01-06 16:05:47 +0000
committerrobertl <robertl@138bc75d-0d04-0410-961f-82ee72b054a4>1999-01-06 16:05:47 +0000
commit27b15aee8a94d918422f532e1abf487d3cb97f37 (patch)
treec6bab0c1dfe2e04b3017f82475e402c802cde6c7 /gcc/configure.in
parent6a0e61386ec5ccf8fac9aff6e6edd25c47e9bb72 (diff)
downloadppe42-gcc-27b15aee8a94d918422f532e1abf487d3cb97f37.tar.gz
ppe42-gcc-27b15aee8a94d918422f532e1abf487d3cb97f37.zip
* configure.in: New flag --with-dwarf2. If set, enables DWARF-2
debugging as default. * config/tm-dwarf2.h: New file. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@24517 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.in')
-rw-r--r--gcc/configure.in9
1 files changed, 9 insertions, 0 deletions
diff --git a/gcc/configure.in b/gcc/configure.in
index 508af5e7aea..6951e6dcd70 100644
--- a/gcc/configure.in
+++ b/gcc/configure.in
@@ -278,6 +278,11 @@ changequote([,])
JAVAGC=$enableval,
JAVAGC=boehm)
+AC_ARG_WITH(dwarf2,
+[ --enable-dwarf2 enable DWARF2 debugging as default.],
+dwarf2="$with_dwarf2",
+dwarf2=no)
+
# Determine the host, build, and target systems
AC_CANONICAL_SYSTEM
@@ -3430,6 +3435,10 @@ if test x"$tmake_file" = x
then tmake_file=$cpu_type/t-$cpu_type
fi
+if test x"$dwarf2" = xyes
+then tm_file="tm-dwarf2.h $tm_file"
+fi
+
if test x$float_format = x
then float_format=i64
fi
OpenPOWER on IntegriCloud