summaryrefslogtreecommitdiffstats
path: root/gcc/configure.ac
diff options
context:
space:
mode:
authorschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2008-09-02 18:43:30 +0000
committerschwab <schwab@138bc75d-0d04-0410-961f-82ee72b054a4>2008-09-02 18:43:30 +0000
commitc3aa71d49773329d5af1212a7738c1ebea8d8787 (patch)
treeae46fa9e2a3bdcd4ac707bf0ab9d7529767481cc /gcc/configure.ac
parent383ab9e5be01f7eed5a48ef0ab9f0a59b729af3f (diff)
downloadppe42-gcc-c3aa71d49773329d5af1212a7738c1ebea8d8787.tar.gz
ppe42-gcc-c3aa71d49773329d5af1212a7738c1ebea8d8787.zip
* configure.ac: Use m4_quote to quote the expansion of m4_do.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@139905 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'gcc/configure.ac')
-rw-r--r--gcc/configure.ac12
1 files changed, 6 insertions, 6 deletions
diff --git a/gcc/configure.ac b/gcc/configure.ac
index f4cff3d114c..37ed6787064 100644
--- a/gcc/configure.ac
+++ b/gcc/configure.ac
@@ -323,14 +323,14 @@ AC_CHECK_TYPES([__int64], [AC_CHECK_SIZEOF(__int64)])
# So, we only use -pedantic if we can disable those warnings.
ACX_PROG_CC_WARNING_OPTS(
- [m4_do([-W -Wall -Wwrite-strings -Wstrict-prototypes ],
- [-Wmissing-prototypes -Wcast-qual])], [loose_warn])
+ m4_quote(m4_do([-W -Wall -Wwrite-strings -Wstrict-prototypes ],
+ [-Wmissing-prototypes -Wcast-qual])), [loose_warn])
ACX_PROG_CC_WARNING_OPTS(
- [m4_do([-Wold-style-definition -Wc++-compat ],
- [-Wmissing-format-attribute])], [strict_warn])
+ m4_quote(m4_do([-Wold-style-definition -Wc++-compat ],
+ [-Wmissing-format-attribute])), [strict_warn])
ACX_PROG_CC_WARNING_ALMOST_PEDANTIC(
- [m4_do([-Wno-long-long -Wno-variadic-macros ],
- [-Wno-overlength-strings])], [strict_warn])
+ m4_quote(m4_do([-Wno-long-long -Wno-variadic-macros ],
+ [-Wno-overlength-strings])), [strict_warn])
ACX_PROG_CC_WARNINGS_ARE_ERRORS([manual], [strict_warn])
# The above macros do nothing if the compiler is not GCC. However, the
OpenPOWER on IntegriCloud