summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authoraldyh <aldyh@138bc75d-0d04-0410-961f-82ee72b054a4>2006-03-10 21:32:39 +0000
committeraldyh <aldyh@138bc75d-0d04-0410-961f-82ee72b054a4>2006-03-10 21:32:39 +0000
commit50996fe55769882de3f410896032c887f0ff0d04 (patch)
treeb51b1aa303e02e5716aae3c43b6434765e778196 /configure.in
parent19dd6f8c05ad9819e7a6eafa174666b43874bcf2 (diff)
downloadppe42-gcc-50996fe55769882de3f410896032c887f0ff0d04.tar.gz
ppe42-gcc-50996fe55769882de3f410896032c887f0ff0d04.zip
* configure.in: Handle --disable-<component> generically.
* configure: Regenerate. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@111941 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in39
1 files changed, 14 insertions, 25 deletions
diff --git a/configure.in b/configure.in
index cd474f1f82b..da7c63f4f5b 100644
--- a/configure.in
+++ b/configure.in
@@ -305,7 +305,6 @@ AC_ARG_ENABLE(libada,
ENABLE_LIBADA=$enableval,
ENABLE_LIBADA=yes)
if test "${ENABLE_LIBADA}" != "yes" ; then
- noconfigdirs="$noconfigdirs target-libada"
noconfigdirs="$noconfigdirs gnattools"
fi
@@ -313,9 +312,6 @@ AC_ARG_ENABLE(libssp,
[ --enable-libssp Builds libssp directory],
ENABLE_LIBSSP=$enableval,
ENABLE_LIBSSP=yes)
-if test "${ENABLE_LIBSSP}" != "yes" ; then
- noconfigdirs="$noconfigdirs target-libssp"
-fi
# Set the default so we build libgcc-math for ix86 and x86_64
AC_ARG_ENABLE(libgcc-math,
@@ -328,9 +324,6 @@ case "${target}" in
enable_libgcc_math=no ;;
esac
])
-if test "${enable_libgcc_math}" != "yes"; then
- noconfigdirs="$noconfigdirs target-libgcc-math"
-fi
# Save it here so that, even in case of --enable-libgcj, if the Java
# front-end isn't enabled, we still get libgcj disabled.
@@ -349,14 +342,8 @@ no)
esac
-# Allow --disable-libmudflap to exclude target-libmudflap
-case $enable_libmudflap in
-yes)
- ;;
-no)
- noconfigdirs="$noconfigdirs target-libmudflap"
- ;;
-"")
+# Disable libmudflap on some systems.
+if test x$enable_libmudflap = x ; then
case "${target}" in
*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
# Enable libmudflap by default in GNU and friends.
@@ -369,16 +356,10 @@ no)
noconfigdirs="$noconfigdirs target-libmudflap"
;;
esac
-esac
+fi
-# Allow --disable-libgomp to exclude target-libgomp
-case $enable_libgomp in
-yes)
- ;;
-no)
- noconfigdirs="$noconfigdirs target-libgomp"
- ;;
-"")
+# Disable libgomp on non POSIX hosted systems.
+if test x$enable_libgomp = x ; then
# Enable libgomp by default on hosted POSIX systems.
case "${target}" in
*-*-linux* | *-*-gnu* | *-*-k*bsd*-gnu)
@@ -393,7 +374,7 @@ no)
noconfigdirs="$noconfigdirs target-libgomp"
;;
esac
-esac
+fi
case "${target}" in
@@ -1337,6 +1318,14 @@ Recognised languages are: ${potential_languages}])
ac_configure_args=`echo " $ac_configure_args" | sed -e 's/ --enable-languages=[[^ ]]*//' -e 's/$/ --enable-languages='"$enable_languages"/ `
fi
+# Handle --disable-<component> generically.
+for dir in $configdirs $build_configdirs $target_configdirs ; do
+ dirname=`echo $dir | sed -e s/target-//g -e s/build-//g -e s/-/_/g`
+ if eval test x\${enable_${dirname}} "=" xno ; then
+ noconfigdirs="$noconfigdirs $dir"
+ fi
+done
+
# Remove the entries in $skipdirs and $noconfigdirs from $configdirs,
# $build_configdirs and $target_configdirs.
# If we have the source for $noconfigdirs entries, add them to $notsupp.
OpenPOWER on IntegriCloud