summaryrefslogtreecommitdiffstats
path: root/configure.ac
diff options
context:
space:
mode:
authorktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2009-11-06 10:16:30 +0000
committerktietz <ktietz@138bc75d-0d04-0410-961f-82ee72b054a4>2009-11-06 10:16:30 +0000
commitfe28477410156dd23a82361d99553973986c932f (patch)
tree077b8d18779bf14df90afd1fa407698da23f01f7 /configure.ac
parente0559d69f5cf440c6b68bb33f4f9982dae4fe395 (diff)
downloadppe42-gcc-fe28477410156dd23a82361d99553973986c932f.tar.gz
ppe42-gcc-fe28477410156dd23a82361d99553973986c932f.zip
2009-11-06 Ozkan Sezer <sezeroz@gmail.com>
* configure.ac (FLAGS_FOR_TARGET): Add -L and -isystem paths for *-w64-mingw* and x86_64-*mingw*. * configure: Regenerated. git-svn-id: svn+ssh://gcc.gnu.org/svn/gcc/trunk@153964 138bc75d-0d04-0410-961f-82ee72b054a4
Diffstat (limited to 'configure.ac')
-rw-r--r--configure.ac26
1 files changed, 16 insertions, 10 deletions
diff --git a/configure.ac b/configure.ac
index 36774a4fe7e..5f7f9d1d33f 100644
--- a/configure.ac
+++ b/configure.ac
@@ -747,10 +747,10 @@ case "${target}" in
i[[3456789]]86-*-mingw*)
target_configdirs="$target_configdirs target-winsup"
noconfigdirs="$noconfigdirs expect target-libgloss target-newlib ${libgcj}"
- ;;
+ ;;
x86_64-*-mingw*)
noconfigdirs="$noconfigdirs expect target-libgloss target-newlib ${libgcj}"
- ;;
+ ;;
*-*-cygwin*)
target_configdirs="$target_configdirs target-libtermcap target-winsup"
noconfigdirs="$noconfigdirs target-gperf target-libgloss"
@@ -760,7 +760,7 @@ case "${target}" in
elif test -d "$srcdir/newlib"; then
echo "Warning: winsup/cygwin is missing so newlib can't be built."
fi
- ;;
+ ;;
i[[3456789]]86-moss-msdos | i[[3456789]]86-*-moss* | \
i[[3456789]]86-*-uwin* | i[[3456789]]86-*-interix* )
;;
@@ -2959,8 +2959,9 @@ case " $target_configdirs " in
case " $target_configargs " in
*" --with-newlib "*)
case "$target" in
- *-cygwin*)
- FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup -L$$r/$(TARGET_SUBDIR)/winsup/cygwin -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/include -isystem $$s/winsup/cygwin/include -isystem $$s/winsup/w32api/include' ;;
+ *-cygwin*)
+ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup -L$$r/$(TARGET_SUBDIR)/winsup/cygwin -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/include -isystem $$s/winsup/cygwin/include -isystem $$s/winsup/w32api/include'
+ ;;
esac
# If we're not building GCC, don't discard standard headers.
@@ -3016,12 +3017,17 @@ case " $target_configdirs " in
esac
;;
esac
+
case "$target" in
-x86_64-*-mingw* | *-w64-mingw*)
- ;;
-*-mingw*)
- # Can't be handled as Cygwin above since Mingw does not use newlib.
- FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup/mingw -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/mingw/include -isystem $$s/winsup/w32api/include' ;;
+ x86_64-*mingw* | *-w64-mingw*)
+ # MinGW-w64 does not use newlib, nor does it use winsup. It may,
+ # however, use a symlink named 'mingw' in ${prefix} .
+ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L${prefix}/${target}/lib -L${prefix}/mingw/lib -isystem ${prefix}/${target}/include -isystem ${prefix}/mingw/include'
+ ;;
+ *-mingw*)
+ # MinGW can't be handled as Cygwin above since it does not use newlib.
+ FLAGS_FOR_TARGET=$FLAGS_FOR_TARGET' -L$$r/$(TARGET_SUBDIR)/winsup/mingw -L$$r/$(TARGET_SUBDIR)/winsup/w32api/lib -isystem $$s/winsup/mingw/include -isystem $$s/winsup/w32api/include'
+ ;;
esac
# Allow the user to override the flags for
OpenPOWER on IntegriCloud