summaryrefslogtreecommitdiffstats
path: root/sim/ppc/configure.in
diff options
context:
space:
mode:
Diffstat (limited to 'sim/ppc/configure.in')
-rw-r--r--sim/ppc/configure.in12
1 files changed, 12 insertions, 0 deletions
diff --git a/sim/ppc/configure.in b/sim/ppc/configure.in
index 7df389f4b1..0a51bdc345 100644
--- a/sim/ppc/configure.in
+++ b/sim/ppc/configure.in
@@ -364,6 +364,17 @@ if test x"$silent" != x"yes"; then
echo "Setting model-issue flags = $sim_model_issue" 6>&1
fi],[sim_model_issue=""])dnl
+AC_ARG_ENABLE(sim-stdio,
+[ --enable-sim-stdio Specify whether to use stdio for console input/output.],
+[case "${enableval}" in
+ yes) sim_stdio="-DWITH_STDIO=DO_USE_STDIO";;
+ no) sim_stdio="-DWITH_STDIO=DONT_USE_STDIO";;
+ *) AC_MSG_ERROR("Unknown value $enableval passed to --enable-sim-stdio"); sim_stdio="";;
+esac
+if test x"$silent" != x"yes" && test x"$sim_stdio" != x""; then
+ echo "Setting stdio flags = $sim_stdio" 6>&1
+fi],[sim_stdio=""])dnl
+
AC_CONFIG_AUX_DIR(`cd $srcdir;pwd`/../..)
AC_CANONICAL_SYSTEM
AC_ARG_PROGRAM
@@ -405,6 +416,7 @@ AC_SUBST(sim_monitor)
AC_SUBST(sim_model)
AC_SUBST(sim_default_model)
AC_SUBST(sim_model_issue)
+AC_SUBST(sim_stdio)
AC_CHECK_FUNCS(getrusage)
OpenPOWER on IntegriCloud