summaryrefslogtreecommitdiffstats
path: root/bfd/doc/Makefile.am
diff options
context:
space:
mode:
Diffstat (limited to 'bfd/doc/Makefile.am')
-rw-r--r--bfd/doc/Makefile.am14
1 files changed, 14 insertions, 0 deletions
diff --git a/bfd/doc/Makefile.am b/bfd/doc/Makefile.am
index 9256bd11ae..d5b3fbabae 100644
--- a/bfd/doc/Makefile.am
+++ b/bfd/doc/Makefile.am
@@ -296,6 +296,20 @@ MAINTAINERCLEANFILES = $(DOCFILES)
# cygnus option.
install: install-info
+pdf__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
+
+install-pdf: install-pdf-am
+
+install-pdf-am: $(PDFS)
+ @$(NORMAL_INSTALL)
+ test -z "$(pdfdir)" || $(mkinstalldirs) "$(DESTDIR)$(pdfdir)"
+ @list='$(PDFS)'; for p in $$list; do \
+ if test -f "$$p"; then d=; else d="$(srcdir)/"; fi; \
+ f=$(pdf__strip_dir) \
+ echo " $(INSTALL_DATA) '$$d$$p' '$(DESTDIR)$(pdfdir)/$$f'"; \
+ $(INSTALL_DATA) "$$d$$p" "$(DESTDIR)$(pdfdir)/$$f"; \
+ done
+
html__strip_dir = `echo $$p | sed -e 's|^.*/||'`;
install-html: install-html-am
OpenPOWER on IntegriCloud