summaryrefslogtreecommitdiffstats
path: root/opcodes/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2000-06-22 13:01:43 +0000
committerAlan Modra <amodra@gmail.com>2000-06-22 13:01:43 +0000
commit1581f8c9feb992568c0f36d2c76d43f7a75a4750 (patch)
treefd86b2f947da0e879eae266d65bddf7d3470dae9 /opcodes/Makefile.am
parent45288df104aeefbd6fb98ac40659b1aec6b6bb65 (diff)
downloadppe42-binutils-1581f8c9feb992568c0f36d2c76d43f7a75a4750.tar.gz
ppe42-binutils-1581f8c9feb992568c0f36d2c76d43f7a75a4750.zip
Ensure /usr/include and the like stay out of dependencies.
Diffstat (limited to 'opcodes/Makefile.am')
-rw-r--r--opcodes/Makefile.am8
1 files changed, 6 insertions, 2 deletions
diff --git a/opcodes/Makefile.am b/opcodes/Makefile.am
index 565b1caf23..f4af0468a9 100644
--- a/opcodes/Makefile.am
+++ b/opcodes/Makefile.am
@@ -250,8 +250,12 @@ ia64-asmtab.c: @MAINT@ ia64-gen ia64-ic.tbl ia64-raw.tbl ia64-waw.tbl ia64-war.t
DEP: dep.sed $(CFILES) $(HFILES) config.h
rm -f DEP1
$(MAKE) MKDEP="$(MKDEP)" DEP1
- sed -f dep.sed < DEP1 > $@
- echo '# IF YOU PUT ANYTHING HERE IT WILL GO AWAY' >> $@
+ if grep ' /' DEP1 > /dev/null 2> /dev/null; then \
+ echo 'make DEP failed!'; exit 1; \
+ else \
+ sed -f dep.sed < DEP1 > $@; \
+ echo '# IF YOU PUT ANYTHING HERE IT WILL GO AWAY' >> $@; \
+ fi
DEP1: $(CFILES)
echo '# DO NOT DELETE THIS LINE -- mkdep uses it.' > DEP2
OpenPOWER on IntegriCloud