summaryrefslogtreecommitdiffstats
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorMike Frysinger <vapier@gentoo.org>2010-11-15 22:30:47 +0000
committerMike Frysinger <vapier@gentoo.org>2010-11-15 22:30:47 +0000
commit781303cee5db333c5635d22bc1f7a0a996b7e0d5 (patch)
tree6fd813d1143496f6284fa88ddfe1b5c95ca91923 /ld/Makefile.am
parentc85f715a62b5282c19da485e133686f29675b801 (diff)
downloadppe42-binutils-781303cee5db333c5635d22bc1f7a0a996b7e0d5.tar.gz
ppe42-binutils-781303cee5db333c5635d22bc1f7a0a996b7e0d5.zip
blackfin: add support for L1 code/data flags
Add new linker options for marking programs to load into L1 memory at runtime. This needs new EF flag bits, so declare them. Signed-off-by: Jie Zhang <jie.zhang@analog.com> Signed-off-by: Mike Frysinger <vapier@gentoo.org>
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am7
1 files changed, 4 insertions, 3 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index b4364be6f1..d9e1bcca24 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -791,11 +791,12 @@ edelta68.c: $(srcdir)/emulparams/delta68.sh \
$(srcdir)/emultempl/generic.em $(srcdir)/scripttempl/delta68.sc ${GEN_DEPENDS}
${GENSCRIPTS} delta68 "$(tdir_delta68)"
eelf32bfin.c: $(srcdir)/emulparams/bfin.sh \
- $(ELF_DEPS) \
+ $(ELF_DEPS) $(srcdir)/emultempl/bfin.em \
$(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} elf32bfin "$(tdir_elf32bfin)" bfin
-eelf32bfinfd.c: $(srcdir)/emulparams/elf32bfinfd.sh $(srcdir)/emulparams/bfin.sh \
- $(ELF_DEPS) \
+eelf32bfinfd.c: $(srcdir)/emulparams/elf32bfinfd.sh \
+ $(srcdir)/emulparams/bfin.sh \
+ $(ELF_DEPS) $(srcdir)/emultempl/bfin.em \
$(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} elf32bfinfd "$(tdir_elf32bfinfd)" elf32bfinfd
eelf32_dlx.c: $(srcdir)/emulparams/elf32_dlx.sh \
OpenPOWER on IntegriCloud