summaryrefslogtreecommitdiffstats
path: root/ld/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2007-02-26 08:58:16 +0000
committerAlan Modra <amodra@gmail.com>2007-02-26 08:58:16 +0000
commit45d3b878abeec9aba15bde906804909c480fbb6f (patch)
tree5495ada8b691a9d71890c8080fae678f0caee051 /ld/Makefile.am
parent56b60c14ab85dadc5eef8af7dcbd5132b69b67eb (diff)
downloadppe42-binutils-45d3b878abeec9aba15bde906804909c480fbb6f.tar.gz
ppe42-binutils-45d3b878abeec9aba15bde906804909c480fbb6f.zip
* emultempl/spuelf.em (_binary_builtin_ovl_mgr_start): Rename
to _binary_spu_ovl_o_start. (_binary_builtin_ovl_mgr_end): Rename to _binary_spu_ovl_o_end. (spu_elf_load_ovl_mgr): Fatal error on missing overlay manager. * emultempl/spu_inc.s: Rename symbols. * emultempl/spu_none.s: New file. * emultempl/spu_ovl.S: Update copyright. * Makefile.am (spu_inc.o): Try building with ld -r first, then gas incbin, then build without overlay manager. * Makefile.in: Regenerate.
Diffstat (limited to 'ld/Makefile.am')
-rw-r--r--ld/Makefile.am10
1 files changed, 8 insertions, 2 deletions
diff --git a/ld/Makefile.am b/ld/Makefile.am
index a62167a753..d83bb16177 100644
--- a/ld/Makefile.am
+++ b/ld/Makefile.am
@@ -724,8 +724,14 @@ eelf32_sparc_vxworks.c: $(srcdir)/emulparams/elf32_sparc_vxworks.sh \
eelf32_spu.c: $(srcdir)/emulparams/elf32_spu.sh $(srcdir)/emultempl/spuelf.em \
$(ELF_DEPS) $(srcdir)/scripttempl/elf.sc ${GEN_DEPENDS}
${GENSCRIPTS} elf32_spu "$(tdir_elf32_spu)"
-spu_inc.o: $(srcdir)/emultempl/spu_inc.s $(srcdir)/emultempl/spu_ovl.o
- $(CC) -c -Wa,-I,$(srcdir)/emultempl -o $@ $<
+spu_inc.o: $(srcdir)/emultempl/spu_inc.s $(srcdir)/emultempl/spu_none.s \
+ $(srcdir)/emultempl/spu_ovl.o
+ cp $(srcdir)/emultempl/spu_ovl.o spu_ovl.o; \
+ if ! ld -r -o $@ -b binary spu_ovl.o; then \
+ if ! $(CC) -c -o $@ $(srcdir)/emultempl/spu_inc.s; then \
+ $(CC) -c -o $@ $(srcdir)/emultempl/spu_none.s; \
+ fi \
+ fi
$(srcdir)/emultempl/spu_ovl.o: @MAINT@ $(srcdir)/emultempl/spu_ovl.S
cpp -DOVLY_IRQ_SAVE $(srcdir)/emultempl/spu_ovl.S spu_ovl.s
if ../gas/as-new --version \
OpenPOWER on IntegriCloud