summaryrefslogtreecommitdiffstats
path: root/gold/testsuite/Makefile.am
diff options
context:
space:
mode:
authorCary Coutant <ccoutant@google.com>2013-05-13 17:35:22 +0000
committerCary Coutant <ccoutant@google.com>2013-05-13 17:35:22 +0000
commit9df9de2ccaad76582d6968d486d54f12e4da659f (patch)
tree9de17ee41a4cec9bb7cde93e17cff59461693226 /gold/testsuite/Makefile.am
parent92ce080be64446a0ca9025211d3be4bd638c0a3c (diff)
downloadppe42-binutils-9df9de2ccaad76582d6968d486d54f12e4da659f.tar.gz
ppe42-binutils-9df9de2ccaad76582d6968d486d54f12e4da659f.zip
gold/
* configure.ac: Export DEFAULT_TARGET. * configure: Regenerate. * Makefile.in: Regenerate. * testsuite/Makefile.am: Add .EXPORT_ALL_VARIABLES. * testsuite/Makefile.in: Regenerate. * testsuite/debug_msg.sh: Delete duplicate tests. Don't check undef_int error message match for powerpc where the source file and line number aren't available.
Diffstat (limited to 'gold/testsuite/Makefile.am')
-rw-r--r--gold/testsuite/Makefile.am25
1 files changed, 4 insertions, 21 deletions
diff --git a/gold/testsuite/Makefile.am b/gold/testsuite/Makefile.am
index a1ac4743e9..785adab974 100644
--- a/gold/testsuite/Makefile.am
+++ b/gold/testsuite/Makefile.am
@@ -53,26 +53,6 @@ TEST_AR = $(top_builddir)/../binutils/ar
TEST_NM = $(top_builddir)/../binutils/nm-new
TEST_AS = $(top_builddir)/../gas/as-new
-# Make the default target available to scripts as $DEFAULT_TARGET.
-if DEFAULT_TARGET_ARM
-export DEFAULT_TARGET = arm
-endif
-if DEFAULT_TARGET_I386
-export DEFAULT_TARGET = i386
-endif
-if DEFAULT_TARGET_POWERPC
-export DEFAULT_TARGET = powerpc
-endif
-if DEFAULT_TARGET_SPARC
-export DEFAULT_TARGET = sparc
-endif
-if DEFAULT_TARGET_X86_64
-export DEFAULT_TARGET = x86_64
-endif
-if DEFAULT_TARGET_TILEGX
-export DEFAULT_TARGET = tilegx
-endif
-
if PLUGINS
LIBDL = -ldl
endif
@@ -91,7 +71,10 @@ endif
# the right choice for files 'make' builds that people rebuild.
MOSTLYCLEANFILES = *.so *.syms *.stdout
-
+# Export make variables to the shell scripts so that they can see
+# (for example) DEFAULT_TARGET.
+.EXPORT_ALL_VARIABLES:
+
# We will add to these later, for each individual test. Note
# that we add each test under check_SCRIPTS or check_PROGRAMS;
# the TESTS variable is automatically populated from these.
OpenPOWER on IntegriCloud