summaryrefslogtreecommitdiffstats
path: root/gdb/configure.in
diff options
context:
space:
mode:
authorAndrew Cagney <cagney@redhat.com>2000-02-23 00:25:43 +0000
committerAndrew Cagney <cagney@redhat.com>2000-02-23 00:25:43 +0000
commitfb40c20903110ed8af9701ce7c2635abd3770d52 (patch)
tree9f99a85a7d64fa61cfa9a167e006e2f747716d42 /gdb/configure.in
parente6c6b6fe2d24c8be4909c7e3c0dd1a937819ffe9 (diff)
downloadppe42-binutils-fb40c20903110ed8af9701ce7c2635abd3770d52.tar.gz
ppe42-binutils-fb40c20903110ed8af9701ce7c2635abd3770d52.zip
Add mi/ and testsuite/gdb.mi/ subdirectories.
Add --enable-gdbmi option to configury. Add mi rules to Makefile.in Add mi conditional output to event-top.c infrun.c main.c top.c. Add -i=mi option.
Diffstat (limited to 'gdb/configure.in')
-rw-r--r--gdb/configure.in32
1 files changed, 29 insertions, 3 deletions
diff --git a/gdb/configure.in b/gdb/configure.in
index 84d9fe240d..cfb8308e61 100644
--- a/gdb/configure.in
+++ b/gdb/configure.in
@@ -41,7 +41,8 @@ dnl List of object files added by configure.
CONFIG_OBS=
CONFIG_DEPS=
CONFIG_SRCS=
-CONFIG_INIT=
+CONFIG_INITS=
+ENABLE_CFLAGS=
configdirs="doc testsuite"
@@ -363,7 +364,30 @@ if test ${build} = ${host} -a ${host} = ${target} ; then
fi
dnl Handle optional features that can be enabled.
-ENABLE_CFLAGS=
+
+dnl Handle MI sub-directory configury.
+AC_ARG_ENABLE(gdbmi,
+[ --enable-gdbmi Enable GDB-MI interface],
+[
+ case "${enable_gdbmi}" in
+ yes | no) ;;
+ "") enable_gdbmi=yes ;;
+ *)
+ AC_MSG_ERROR(Bad value for --enable-gdbmi: ${enableval})
+ ;;
+ esac
+])
+case ${enable_gdbmi} in
+ "yes" )
+ if test -d "${srcdir}/mi" ; then
+ CONFIG_OBS="${CONFIG_OBS} \$(SUBDIR_MI_OBS)"
+ CONFIG_DEPS="${CONFIG_DEPS} \$(SUBDIR_MI_DEPS)"
+ CONFIG_SRCS="${CONFIG_SRS} \$(SUBDIR_MI_SRCS)"
+ CONFIG_INITS="${CONFIG_INITS} \$(SUBDIR_MI_INITS)"
+ ENABLE_CFLAGS="${ENABLE_CFLAGS} \${SUBDIR_MI_CFLAGS)"
+ fi
+ ;;
+esac
AC_ARG_ENABLE(tui,
[ --enable-tui Enable full-screen terminal user interface],
@@ -406,7 +430,9 @@ fi
AC_ARG_ENABLE(build-warnings,
[ --enable-build-warnings Enable build-time compiler warnings if gcc is used],
-[build_warnings="-Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations"
+[
+# not yet: -Wall -Wpointer-arith -Wstrict-prototypes -Wmissing-prototypes -Wmissing-declarations
+build_warnings="-Wimplicit -Wreturn-type -Wcomment -Wtrigraphs -Wformat -Wparentheses -Wpointer-arith"
case "${enableval}" in
yes) ;;
no) build_warnings="-w";;
OpenPOWER on IntegriCloud