summaryrefslogtreecommitdiffstats
path: root/gdb/configure.ac
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2009-04-21 20:13:08 +0000
committerJoseph Myers <joseph@codesourcery.com>2009-04-21 20:13:08 +0000
commit26e251b60395cf60fd81e6e10ab2c487f75f0164 (patch)
tree9b59a331d0a8fdffe7e3d43c3bda04ce156077c8 /gdb/configure.ac
parent32c1c914bc653cb5bd8cb627d244d1142172bb76 (diff)
downloadppe42-binutils-26e251b60395cf60fd81e6e10ab2c487f75f0164.tar.gz
ppe42-binutils-26e251b60395cf60fd81e6e10ab2c487f75f0164.zip
gdb:
* configure.ac (--with-datarootdir, --with-docdir, --with-pdfdir, --with-htmldir): New. * configure: Regenerate. gdb/doc: * configure.ac (--with-datarootdir, --with-docdir, --with-pdfdir, --with-htmldir): New. * configure: Regenerate. * Makefile.in (datarootdir, docdir): Define. (gdb.dvi, gdb.pdf): Use same -I options as for building gdb.info instead of $(SET_TEXINPUTS). (gdbint.dvi, gdbint.pdf): Use same -I options as for building gdbint.info instead of $(SET_TEXINPUTS). (gdbint/index.html): Use same -I options as for building gdbint.info. (stabs.dvi, stabs.pdf): Use same -I options as for building stabs.info instead of $(SET_TEXINPUTS). (stabs/index.html): Use same -I options as for building stabs.info. (annotate.dvi, annotate.pdf): Use same -I options as for building annotate.info instead of $(SET_TEXINPUTS). (annotate/index.html): Use same -I options as for building annotate.info.
Diffstat (limited to 'gdb/configure.ac')
-rw-r--r--gdb/configure.ac22
1 files changed, 21 insertions, 1 deletions
diff --git a/gdb/configure.ac b/gdb/configure.ac
index ff83563b9f..e52b77c1b2 100644
--- a/gdb/configure.ac
+++ b/gdb/configure.ac
@@ -1960,7 +1960,27 @@ dnl At the moment, we just assume it's UTF-8.
AC_DEFINE(GDB_DEFAULT_HOST_CHARSET, "UTF-8",
[Define to be a string naming the default host character set.])
-dnl Required by html, pdf, install-pdf and install-html
+# Flags needed to enable html installing and building
+AC_ARG_WITH(datarootdir,
+AC_HELP_STRING([--with-datarootdir], [use datarootdir as the data root directory.]),
+[datarootdir="\${prefix}/${withval}"],
+[datarootdir="\${prefix}/share"])
+
+AC_ARG_WITH(docdir,
+AC_HELP_STRING([--with-docdir], [install documentation in this directory.]),
+[docdir="\${prefix}/${withval}"],
+[docdir="\${datarootdir}/doc"])
+
+AC_ARG_WITH(pdfdir,
+AC_HELP_STRING([--with-pdfdir], [install pdf in this directory.]),
+[pdfdir="\${prefix}/${withval}"],
+[pdfdir="\${docdir}"])
+
+AC_ARG_WITH(htmldir,
+AC_HELP_STRING([--with-htmldir], [install html in this directory.]),
+[htmldir="\${prefix}/${withval}"],
+[htmldir="\${docdir}"])
+
AC_SUBST(datarootdir)
AC_SUBST(docdir)
AC_SUBST(htmldir)
OpenPOWER on IntegriCloud