summaryrefslogtreecommitdiffstats
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorJan Beulich <jbeulich@novell.com>2009-04-20 06:31:50 +0000
committerJan Beulich <jbeulich@novell.com>2009-04-20 06:31:50 +0000
commitee86248ceef0286d7b2b074a88718176ebd6ada6 (patch)
treeee530c29f83602fa33bbeea24f955312896842f0 /gas/Makefile.am
parentfcaed75e5235a983da6edd87da4eadcf27b99fb7 (diff)
downloadppe42-binutils-ee86248ceef0286d7b2b074a88718176ebd6ada6.tar.gz
ppe42-binutils-ee86248ceef0286d7b2b074a88718176ebd6ada6.zip
gas/
2009-04-20 Jan Beulich <jbeulich@novell.com> * Makefile.am: Add explicit dependency of tc-i386.o on tc-i386-intel.c. * Makefile.in: Likewise. * config/tc-i386.c (i386_finalize_immediate): Declare, broken out from i386_immediate. (i386_immediate): Slightly re-arrange, call i386_finalize_immediate. (i386_finalize_displacement): Declare, broken out from i386_displacement. (i386_displacement): Slightly re-arrange, call i386_finalize_displacement. (i386_intel_simplify, i386_intel_parse_name): Declare. (this_operand): Initialize to -1. (set_intel_syntax): Set expression rank for O_full_ptr. (md_assemble): Set this_operand back to -1 after parsing operands. (x86_cons): Negate intel_syntax to indicate state. Call i386_intel_simplify. (md_operand): Convert if to switch. Handle '[' for Intel syntax. (i386_intel_operand): Delete, including all helper functions and data. * config/tc-i386-intel.c: New file, all new code. * config/tc-i386.h (i386_operator): Declare. (md_operator): Define to i386_operator. (i386_need_index_operator): Declare. (md_need_index_operator): Define to i386_need_index_operator. (O_full_ptr): Define. gas/testsuite/ 2009-04-20 Jan Beulich <jbeulich@novell.com> * gas/i386/equ.s: Adjust. * gas/i386/equ.d: Remove reference to equ.e. * gas/i386/equ.e: Delete. * gas/i386/intel-expr.s: New. * gas/i386/intel-expr.d: New. * gas/i386/i386.exp: Run new test. * gas/i386/intel.s: Adjust. * gas/i386/intel.e: Remove no longer valid warning messages. * gas/i386/intel16.s: Adjust. * gas/i386/intel16.d: Remove reference to intel16.e. * gas/i386/intel16.e: Delete. * gas/i386/intelbad.s: Add more tests. * gas/i386/intelbad.l: Adjust. * gas/i386/intelok.s: Remove now unneeded equates. Add more tests. * gas/i386/intelok.d: Remove reference to intelok.e. Adjust. * gas/i386/intelok.e: Delete. * gas/i386/x86_64.s: Adjust. * gas/i386/x86_64.d: Remove reference to x86_64.e. * gas/i386/x86_64.e: Delete.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index f5c7a84ad7..40c52be39e 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -614,6 +614,8 @@ e-crisaout.o: $(srcdir)/config/e-crisaout.c
e-criself.o: $(srcdir)/config/e-criself.c
$(COMPILE) -c $(srcdir)/config/e-criself.c
+tc-i386.o: $(srcdir)/config/tc-i386-intel.c
+
xtensa-relax.o: $(srcdir)/config/xtensa-relax.c
$(COMPILE) -c $(srcdir)/config/xtensa-relax.c
OpenPOWER on IntegriCloud