summaryrefslogtreecommitdiffstats
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorAlan Modra <amodra@gmail.com>2009-06-04 06:57:12 +0000
committerAlan Modra <amodra@gmail.com>2009-06-04 06:57:12 +0000
commit26d1917c555cb057baa061fa476ec0e5c0965280 (patch)
tree20b4af6ee05ab3cdb9e2b8576d75c14ca05ad9e0 /gas/Makefile.am
parent4b9d2a998bc949c056e4a37f0942e3ea0571376a (diff)
downloadppe42-binutils-26d1917c555cb057baa061fa476ec0e5c0965280.tar.gz
ppe42-binutils-26d1917c555cb057baa061fa476ec0e5c0965280.zip
* dep-in.sed: Don't use \n in replacement part of s command.
* Makefile.am (DEP1, DEPTC, DEPOBJ, DEP2): LC_ALL for uniq. * Makefile.in: Regenerate.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am9
1 files changed, 5 insertions, 4 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index e12012a01e..0b66f41cc3 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -922,7 +922,8 @@ DEP1: $(CFILES) $(MULTI_CFILES)
for f in $?; do \
$(MKDEP) $(DEP_FLAGS) $$f > DEP; \
sed -n -e '1s/: .*/: \\/p' -e q < DEP >> DEP2; \
- sed -e '1s/.*://' -f ../dep.sed < DEP | LC_ALL=C sort | uniq | \
+ sed -e '1s/.*://' -f ../dep.sed < DEP | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e 's/^[AB]/ /' -e '$$s/ \\$$//' >> DEP2; \
done
mv -f DEPDIR/DEP2 $@
@@ -952,7 +953,7 @@ DEPTC: $(TARGET_CPU_CFILES)
echo "DEPTC_$${c}_$${o} = \\" >> ../DEPTCA; \
$(MKDEP) $(DEP_FLAGS) dumtc.c | \
sed -e '1s/dumtc.o: //' -f ../dep.sed | \
- LC_ALL=C sort | uniq | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e '/^A/d' -e 's/^B/ /' -e '$$s/ \\$$//' >> ../DEPTCA; \
rm -f dumtc.c; \
else true; fi; \
@@ -993,7 +994,7 @@ DEPOBJ: $(OBJ_FORMAT_CFILES)
echo "DEPOBJ_$${c}_$${o} = \\" >> ../DEPOBJA; \
$(MKDEP) $(DEP_FLAGS) dumobj.c | \
sed -e "s/dumobj.o: //" -f ../dep.sed | \
- LC_ALL=C sort | uniq | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e '/^A/d' -e 's/^B/ /' -e '$$s/ \\$$//' >> ../DEPOBJA; \
rm -f dumobj.c; \
else true; fi; \
@@ -1031,7 +1032,7 @@ DEP2: $(TARGET_CPU_HFILES) $(OBJ_FORMAT_HFILES)
echo "DEP_$${c}_$${o} = \\" >> ../DEP2A; \
$(MKDEP) $(DEP_FLAGS) dummy.c | \
sed -e "s/dummy.o: //" -f ../dep.sed | \
- LC_ALL=C sort | uniq | \
+ LC_ALL=C sort | LC_ALL=C uniq | \
sed -e '/^A/d' -e 's/^B/ /' -e '$$s/ \\$$//' >> ../DEP2A; \
else true; fi; \
done; \
OpenPOWER on IntegriCloud