summaryrefslogtreecommitdiffstats
path: root/gas/Makefile.am
diff options
context:
space:
mode:
authorJoseph Myers <joseph@codesourcery.com>2010-02-05 12:43:09 +0000
committerJoseph Myers <joseph@codesourcery.com>2010-02-05 12:43:09 +0000
commit1e4cb85751694bf433e5146763241448c7eb2dde (patch)
treee7ebddeab2f11474b818a857ad3b64a6e6151f06 /gas/Makefile.am
parentd18b8b7a0759b26ebc14eab4e95f643e142a24de (diff)
downloadppe42-binutils-1e4cb85751694bf433e5146763241448c7eb2dde.tar.gz
ppe42-binutils-1e4cb85751694bf433e5146763241448c7eb2dde.zip
* Makefile.am (CPU_TYPES, OBJ_FORMATS, CPU_OBJ_VALID,
MULTI_CPU_TYPES, MULTI_CPU_OBJ_VALID): Remove. * Makefile.in: Regenerate.
Diffstat (limited to 'gas/Makefile.am')
-rw-r--r--gas/Makefile.am136
1 files changed, 0 insertions, 136 deletions
diff --git a/gas/Makefile.am b/gas/Makefile.am
index 87fbe3c51e..92f3b8745c 100644
--- a/gas/Makefile.am
+++ b/gas/Makefile.am
@@ -36,142 +36,6 @@ IT_SRCS=itbl-parse.c itbl-lex.c $(srcdir)/itbl-ops.c
IT_DEPS=$(srcdir)/itbl-parse.y $(srcdir)/itbl-lex.l $(srcdir)/config/itbl-@target_cpu_type@.h
IT_OBJS=itbl-parse.o itbl-lex.o itbl-ops.o
-# CPU types. This is only used for dependency information.
-
-CPU_TYPES = \
- alpha \
- arc \
- arm \
- avr \
- bfin \
- cr16 \
- cris \
- crx \
- d10v \
- d30v \
- dlx \
- fr30 \
- frv \
- h8300 \
- hppa \
- i370 \
- i386 \
- i860 \
- i960 \
- ia64 \
- ip2k \
- lm32 \
- m32c \
- m32r \
- m68hc11 \
- m68k \
- maxq \
- mcore \
- mep \
- microblaze \
- mips \
- mmix \
- mn10200 \
- mn10300 \
- msp430 \
- mt \
- ns32k \
- openrisc \
- or32 \
- pdp11 \
- pj \
- ppc \
- rx \
- s390 \
- score \
- sh \
- sh64 \
- sparc \
- spu \
- tic30 \
- tic4x \
- tic54x \
- v850 \
- vax \
- xc16x \
- xstormy16 \
- xtensa \
- z80 \
- z8k
-
-# Object format types. This is only used for dependency information.
-# We deliberately omit SOM, since it does not work as a cross assembler.
-
-OBJ_FORMATS = \
- aout \
- coff \
- ecoff \
- elf \
- evax \
- macho
-
-# This is an sh case which sets valid according to whether the CPU
-# type in the shell variable c and the OS type in the shell variable o
-# are supported. This helps cuts down on the amount of dependency
-# information.
-
-CPU_OBJ_VALID = \
- valid= ; \
- case $$o in \
- aout) \
- case $$c in \
- arm | cris | i386 | m68k | ns32k | pdp11 | sparc | tic30 | vax) \
- valid=yes ;; \
- esac ;; \
- coff) \
- case $$c in \
- arm | h8300 | i386 | i960 | m68k | maxq | mcore | mips | or32 \
- | ppc | sh | sparc | tic* | xscale | z80 | z8k) \
- valid=yes ;; \
- esac ;; \
- ecoff) \
- case $$c in \
- mips | alpha) valid=yes ;; \
- esac ;; \
- elf) valid=yes ; \
- case $$c in \
- maxq | ns32k | tic* | z80 | z8k) valid= ;; \
- esac ;; \
- evax) \
- case $$c in \
- alpha) valid=yes ;; \
- esac ;; \
- macho) \
- case $$c in \
- i386) valid=yes ;; \
- esac ;; \
- vms) \
- case $$c in \
- vax) valid=yes ;; \
- esac ;; \
- esac;
-
-# These are like CPU_TYPES and CPU_OBJ_VALID, for the obj=multi case.
-
-MULTI_CPU_TYPES = i386 mips cris
-
-MULTI_CPU_OBJ_VALID = \
- valid= ; \
- case $$o in \
- aout) \
- case $$c in \
- i386 | cris) valid=yes ;; \
- esac ;; \
- coff) \
- case $$c in \
- i386 | mips) valid=yes ;; \
- esac ;; \
- ecoff) \
- case $$c in \
- mips) valid=yes ;; \
- esac ;; \
- elf) valid=yes ;; \
- esac;
# Regular source files.
OpenPOWER on IntegriCloud