summaryrefslogtreecommitdiffstats
path: root/configure.in
diff options
context:
space:
mode:
authorNathanael Nerode <neroden@gcc.gnu.org>2004-03-16 00:04:59 +0000
committerNathanael Nerode <neroden@gcc.gnu.org>2004-03-16 00:04:59 +0000
commit1d39f3299631af4b58eb450f2a3d702fdda2c803 (patch)
treeb0a7f607f3487b4dc08e4eea9af9b77902c97fb2 /configure.in
parentb2fb5b54bfec82dd1280157d8700db9ef20dc73e (diff)
downloadppe42-binutils-1d39f3299631af4b58eb450f2a3d702fdda2c803.tar.gz
ppe42-binutils-1d39f3299631af4b58eb450f2a3d702fdda2c803.zip
2004-03-15 Nathanael Nerode <neroden@gcc.gnu.org>
* Makefile.tpl: Introduce experimental top level bootstrap support. * Makefile.in: Regenerate. * configure.in: Introduce support for top level bootstrap. * configure: Regenerate.
Diffstat (limited to 'configure.in')
-rw-r--r--configure.in52
1 files changed, 49 insertions, 3 deletions
diff --git a/configure.in b/configure.in
index 6fa30221c5..a5ba6e2cad 100644
--- a/configure.in
+++ b/configure.in
@@ -1070,6 +1070,10 @@ fi
ACX_PROG_GNAT
+# By default, C is the only stage 1 langauge.
+stage1_languages=c
+AC_SUBST(stage1_languages)
+
# Figure out what language subdirectories are present.
# Look if the user specified --enable-languages="..."; if not, use
# the environment variable $LANGUAGES if defined. $LANGUAGES might
@@ -1132,10 +1136,11 @@ if test -d ${srcdir}/gcc; then
${srcdir}/gcc/[[*]]/config-lang.in) ;;
*)
# From the config-lang.in, get $language, $target_libs,
- # $lang_dirs, and $build_by_default
+ # $lang_dirs, $boot_language, and $build_by_default
language=
target_libs=
lang_dirs=
+ boot_language=
build_by_default=
. ${lang_frag}
# This is quite sensitive to the ordering of the case statement arms.
@@ -1168,10 +1173,18 @@ if test -d ${srcdir}/gcc; then
case $add_this_lang in
no)
# Remove language-dependent dirs.
- eval noconfigdirs='"$noconfigdirs "'\"$target_libs $lang_dirs\" ;;
+ eval noconfigdirs='"$noconfigdirs "'\"$target_libs $lang_dirs\"
+ ;;
*)
new_enable_languages="$new_enable_languages,$language"
- missing_languages=`echo "$missing_languages" | sed "s/,$language,/,/"` ;;
+ missing_languages=`echo "$missing_languages" | sed "s/,$language,/,/"`
+ case ${boot_language} in
+ yes)
+ # Add to (space-separated) list of stage 1 languages.
+ stage1_languages="${stage1_languages} ${language}"
+ ;;
+ esac
+ ;;
esac
;;
esac
@@ -2184,4 +2197,37 @@ fi
MAINT=$MAINTAINER_MODE_TRUE
AC_SUBST(MAINT)dnl
+# ---------------------
+# GCC bootstrap support
+# ---------------------
+
+# Stage specific cflags for build.
+stage1_cflags="-g"
+case $build in
+ vax-*-*)
+ case ${GCC} in
+ yes) stage1_cflags="-g -Wa,-J" ;;
+ *) stage1_cflags="-g -J" ;;
+ esac ;;
+ powerpc-*-darwin*)
+ # The spiffy cpp-precomp chokes on some legitimate constructs in GCC
+ # sources; use -no-cpp-precomp to get to GNU cpp.
+ # Apple's GCC has bugs in designated initializer handling, so disable
+ # that too.
+ stage1_cflags="-g -no-cpp-precomp -DHAVE_DESIGNATED_INITIALIZERS=0"
+ ;;
+esac
+AC_SUBST(stage1_cflags)
+
+# Enable -Werror in bootstrap stage2 and later.
+# Change the default to "no" on release branches.
+AC_ARG_ENABLE(werror,
+[ --enable-werror enable -Werror in bootstrap stage2 and later], [],
+[enable_werror=yes])
+case ${enable_error} in
+ yes) WERROR=-Werror ;;
+ *) WERROR= ;;
+esac
+AC_SUBST(WERROR)
+
AC_OUTPUT(Makefile)
OpenPOWER on IntegriCloud